0

I am trying to update my packages through the graphic package manager.

I get the error unable to lock database. Everything on the internet says that if this error occurs, a db.lck file should appear in the /var/lib/pacman folder. But it isn't there.

If I try to update with the command line, it works great:

sudo pacman -Syu

What did I miss?

0

Same here -- note that if you click 'ok' and then 'apply' again - it will work. This only started happening recently and I assume is related to the 'update' GUI rather then pacman..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.