0

I tried to install docker on my raspbian install and accidentally broke apt-get

If I run apt-get install or upgrade, I get the following error:

E: The package debconf needs to be reinstalled, but I can't find an archive for it.

I've tried all the suggested solutions I could find online, some examples:

Command:

apt-get -f install debconf

Result:

root@raspberrypi:~# apt-get -f install debconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.

Command:

dpkg-reconfigure debconf

Result:

root@raspberrypi:~# dpkg-reconfigure debconf
/usr/sbin/dpkg-reconfigure: debconf is broken or not fully installed

Command:

apt-get install --reinstall debconf

Result:

root@raspberrypi:~# apt-get install --reinstall debconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.

Command:

dpkg --remove --force-remove-reinstreq debconf

Result:

root@raspberrypi:/var/cache/apt/archives# dpkg-reconfigure debconf
/usr/sbin/dpkg-reconfigure: debconf is broken or not fully installed
root@raspberrypi:/var/cache/apt/archives# sudo dpkg --configure -a
Setting up libc6-dbg:armhf (2.19-18+deb8u10) ...
dpkg: dependency problems prevent configuration of debconf-i18n:
debconf-i18n depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-i18n (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of debconf-utils:
debconf-utils depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-utils (--configure):
dependency problems - leaving unconfigured
Setting up python-software-properties (0.92.25debian1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-software-properties (--configure):
subprocess installed post-installation script returned error exit status 1
Setting up perl-modules (5.20.2-3+deb8u8) ...
Setting up perl (5.20.2-3+deb8u8) ...
Setting up libtirpc1:armhf (0.2.5-1+deb8u1) ...
Setting up libc-dev-bin (2.19-18+deb8u10) ...
Setting up libperl5.20 (5.20.2-3+deb8u8) ...
Setting up libc6-dev:armhf (2.19-18+deb8u10) ...
Setting up rpcbind (0.2.1-6+deb8u2) ...
insserv: warning: current start runlevel(s) (empty) of script `rpcbind' overrides LSB defaults (S).
insserv: warning: current stop runlevel(s) (0 1 6 S) of script `rpcbind' overrides LSB defaults (0 1 6).
Processing triggers for libc-bin (2.19-18+deb8u10) ...
Errors were encountered while processing:
debconf-i18n
debconf-utils
python-software-properties
root@raspberrypi:/var/cache/apt/archives# sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.
root@raspberrypi:/var/cache/apt/archives# sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of debconf-i18n:
debconf-i18n depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-i18n (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of debconf-utils:
debconf-utils depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-utils (--configure):
dependency problems - leaving unconfigured
Setting up python-software-properties (0.92.25debian1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-software-properties (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
debconf-i18n
debconf-utils
python-software-properties
root@raspberrypi:/var/cache/apt/archives# apt-get -f install debconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.
root@raspberrypi:/var/cache/apt/archives# cd
root@raspberrypi:~# apt-get -f install debconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.
root@raspberrypi:~# dpkg-reconfigure debconf
/usr/sbin/dpkg-reconfigure: debconf is broken or not fully installed
root@raspberrypi:~# apt-get install --reinstall debconf
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.
root@raspberrypi:~# dpkg --remove --force-remove-reinstreq debconf
dpkg: dependency problems prevent removal of debconf:
tasksel depends on debconf (>= 0.5) | debconf-2.0; however:
Package debconf is to be removed.
Package debconf-2.0 is not installed.
Package debconf which provides debconf-2.0 is to be removed.
tasksel depends on debconf (>= 1.5.34) | cdebconf (>= 0.106); however:
Package debconf is to be removed.
Package cdebconf is not installed.
tasksel depends on debconf (>= 0.5) | debconf-2.0; however:
Package debconf is to be removed.
Package debconf-2.0 is not installed.
Package debconf which provides debconf-2.0 is to be removed.
tasksel depends on debconf (>= 1.5.34) | cdebconf (>= 0.106); however:
Package debconf is to be removed.
Package cdebconf is not installed.
locales depends on debconf (>= 0.5) | debconf-2.0; however:
Package debconf is to be removed.
Package debconf-2.0 is not installed.
Package debconf which provides debconf-2.0 is to be removed.
ca-certificates depends on debconf (>= 0.5) | debconf-2.0; however:
Package debcon
dpkg: error processing package debconf (--remove):
dependency problems - not removing
Errors were encountered while processing:
debconf

Command:

dpkg --configure -a

Result:

root@raspberrypi:~# dpkg --configure -a
dpkg: dependency problems prevent configuration of debconf-i18n:
debconf-i18n depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-i18n (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of debconf-utils:
debconf-utils depends on debconf (= 1.5.56+deb8u1); however:
Version of debconf on system is 1.5.56.

dpkg: error processing package debconf-utils (--configure):
dependency problems - leaving unconfigured
Setting up python-software-properties (0.92.25debian1) ...
Traceback (most recent call last):
File "/usr/bin/pycompile", line 35, in <module>
    from debpython.version import SUPPORTED, debsorted, vrepr, \
File "/usr/share/python/debpython/version.py", line 24, in <module>
    from ConfigParser import SafeConfigParser
ImportError: No module named 'ConfigParser'
dpkg: error processing package python-software-properties (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
debconf-i18n
debconf-utils
python-software-properties

Command:

dpkg -C

Result:

The following packages are in a mess due to serious problems during
installation.  They must be reinstalled for them (and any packages
that depend on them) to function properly:
debconf              Debian configuration management system

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
debconf-i18n         full internationalization support for debconf
debconf-utils        debconf utilities

The following packages are only half configured, probably due to problems
configuring them the first time.  The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
python-software-properties manage the repositories that you install software f

Command:

apt-cache policy

Result:

root@raspberrypi:~# apt-cache policy
Package files:
100 /var/lib/dpkg/status
    release a=now
500 http://archive.raspberrypi.org/debian/ jessie/ui armhf Packages
    release o=Raspberry Pi Foundation,a=stable,n=jessie,l=Raspberry Pi Foundation,c=ui
    origin archive.raspberrypi.org
500 http://archive.raspberrypi.org/debian/ jessie/main armhf Packages
    release o=Raspberry Pi Foundation,a=stable,n=jessie,l=Raspberry Pi Foundation,c=main
    origin archive.raspberrypi.org
Pinned packages:

Command:

apt-get -f install

Result:

root@raspberrypi:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: The package debconf needs to be reinstalled, but I can't find an archive for it.

Command:

cat /etc/*-release

Result:

root@raspberrypi:~# cat /etc/*-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

Command:

apt-cache policy debconf debconf-i18n debconf-utils

Result:

root@raspberrypi:~# apt-cache policy debconf debconf-i18n debconf-utils
debconf:
Installed: 1.5.56
Candidate: 1.5.56
Version table:
*** 1.5.56 0
        100 /var/lib/dpkg/status
debconf-i18n:
Installed: 1.5.56+deb8u1
Candidate: 1.5.56+deb8u1
Version table:
*** 1.5.56+deb8u1 0
        100 /var/lib/dpkg/status
debconf-utils:
Installed: 1.5.56+deb8u1
Candidate: 1.5.56+deb8u1
Version table:
*** 1.5.56+deb8u1 0
        100 /var/lib/dpkg/status

Command:

cat /etc/apt/sources.list

Result:

root@raspberrypi:~# cat /etc/apt/sources.list
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

Command:

ls -Al /etc/apt/sources.list.d/

Result:

root@raspberrypi:~# ls -Al /etc/apt/sources.list.d/
total 4
-rw-r--r-- 1 root root 193 Apr 10 09:58 raspi.list

Command:

cat /etc/apt/sources.list.d/raspi.list

Result:

root@raspberrypi:~# cat /etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ jessie main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ jessie main ui

Anyone have any clue what to try next?

Would love not to have to reinstall the OS.

  • Please paste the output for the commands you have listed above. Without that, we have no information about what is going on. – Faheem Mitha Aug 16 '17 at 9:01
  • There, updated the post. Any suggestions? – Bobbzorzen Aug 16 '17 at 9:09
  • Thank you, that's informative. Can you add the output of dpkg -C, please? And also paste the output of apt-cache policy. And what release of raspbian is this? "debconf-utils depends on debconf (= 1.5.56+deb8u1); however: Version of debconf on system is 1.5.56." suggests you have a version mismatch. Also, apt-get -f install debconf is not correct syntax. It's just apt-get -f install. You might as well add the output for that too. – Faheem Mitha Aug 16 '17 at 15:15
  • There we go, updated with the suggested commands and the output from cat /etc/*-release for os info. Need anything else? – Bobbzorzen Aug 16 '17 at 18:15
  • No, just apt-get -f install. You did apt-get -f install debconf again. You now have that twice. And yes, let's have the output of apt-cache policy debconf debconf-i18n debconf-utils. – Faheem Mitha Aug 16 '17 at 19:49
3

You're missing your main Raspbian archive, which should be in your sources.list:

anthony@Kilby:~ $ cat /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

Without that, there is nowhere to download debconf 1.5.56+deb8u1 from.

It's likely that adding the source back, then apt-get update, then apt-get install -f will be sufficient to fix it. If not, you'll need to manually download http://mirrordirector.raspbian.org/raspbian/pool/main/d/debconf/debconf_1.5.56+deb8u1_all.deb and install it with dpkg -i debconf_1.5.56+deb8u1_all.deb. Ways of manually downloading that include wget/curl or apt-get download debconf=1.5.56+deb8u1. The latter is easiest if it works.

|improve this answer|||||
  • That seems to solve the problem partly, i no longer get ´E: The package debconf needs to be reinstalled, but I can't find an archive for it.´ instead i get this when trying to install things: gist.github.com/bobbzorzen/28bb22ecfdabbb76a118be81602b25c4 Is this an unrelated error? if so i'll accept your answer. – Bobbzorzen Aug 21 '17 at 7:53
  • Seems like i had gotten python 3.4.x as my default version so that messed up with some python 2.7 install scripts. changed it back using update-alternatives and now it seems to work. Thanks everyone :) – Bobbzorzen Aug 21 '17 at 8:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.