0

We regularly install Fedora behind a firewall without Internet access for the system. The install is fully automated with kickstart and normally takes 10-15 minutes. All packages are installed from a local mirror of the Fedora repos that we keep behind the firewall. With Fedora 26, we found it is now taking nearly an hour to install, a regression from our previous Fedora 24 and 25 installs using nearly identical kickstart files. It appears that Fedora 26 spends 45 minutes repeatedly trying to access codecs.fedoraproject.org, a repo site for the OpenH264 codecs which we have no use for. The installer only proceeds after it gives up 45 minutes later and then proceeds to install normally.

Loading up the ISO and attempting a manual, interactive install shows something similar. For about 45 minutes, the Installation Source and Software Selection menus are grayed out with the message "Downloading group metadata..." One it times out, the user can proceed and finish the install.

How do we disable Fedora 26 from trying to connect to codecs.fedoraproject.org?

Update: This appears to be a known issue with the Fedora 26 installer and is discussed here: https://github.com/rhinstaller/anaconda/pull/1145

  • Disable the repo in /etc/yum.repos.d/fedora-cisco-openh264.repo by setting enabled=0 perhaps? – NickD Aug 14 '17 at 22:59
  • @nick This is during the initial install of Fedora. I need a line I can add to kickstart. – penguin359 Aug 14 '17 at 23:03
  • Once installed, that repo is indeed already set to enabled=0, but it still hung during install. – penguin359 Aug 14 '17 at 23:04
  • how about excluding the package that contains these codecs. – mdpc Aug 14 '17 at 23:29
  • @mdpc Nothing we do has any use for proprietary software. We install with a fairly minimal amount of packages. Nothing should be getting installed from this repo. In fact, the whole point behind this hang is that is can't access that repo, but it never throws any errors about missing packages during the install. – penguin359 Aug 14 '17 at 23:32
1

Looks like there's a fix that will land for F27. In the meantime, I think you should be able to

rm /etc/anaconda.repos.d/fedora-cisco-openh264.repo

in the %pre section of your kickstart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.