0

I'm running Linux Mint 18.1 MATE Edition on my Acer Aspire R14 R5-471T-51UN.

Problem 1 is semi fixed: When the laptop went into suspend mode while on battery when I awakened it to log back in the keyboard quit working (except for the function buttons/features). I was unable to type anything. Using the on-screen keyboard in the login screen I was able to log in but still unable to type anything or use Alt-Tab, etc.

The suggestion I found was to edit grub via this answer:

https://askubuntu.com/a/940323/177637

Basically, run this in a shell to confirm you are applicable to this solution:

dmesg | grep i8042 and confirm you get this output

[ 1.514469] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUE] at

0x60,0x64 irq 1,12 [ 1.525273] serio: i8042 KBD port at 0x60,0x64 irq 1 ?[ 1.525287] serio: i8042 AUX port at 0x60,0x64 irq 12 [ 1.526035] input: AT Raw Set 2 keyboard as /devices/platform/i8042/serio0/input/input3 [ 21.927438] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input10 then, add the boot parameters i8042.direct and i8042.dumbkbd to >/etc/default/grub.

For example, run

sudo nano /etc/default/grub Find the line that begins GRUB_CMDLINE_LINUX_DEFAULT= and edit it to >include the new parameters, so that after your edit it looks something >like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.direct i8042.dumbkbd" Save by pressing Ctrl+O, exit by pressing Ctrl+X, and run

sudo update-grub

Problem 2: My right, up, and down arrow keys don't work now, which has disabled my ability to brighten or dim the screen and raise or lower the volume using the Function key, and many more obvious problems. My left arrow key works.

The Pg Up (Home) and Pg Dn (End) buttons (functions) do work, they are right next to arrow keys.

I don't know what to do to fix this. It's so odd!!

In my Keyboard settings I have English (US) selected and Acer Laptop selected as the model. I've tried other options and it doesn't change anything.

"Reset to Default" for Options has been hit numerous times in the hopes that it would fix it. I never did modify anything as far as keyboard, layout, shortcuts, or locale goes.

Problem 3: Occasionally the entire keyboard quits working without a known reason why. The only way I've found to restore it is to restart the computer.

Any help is appreciated.

dmesg: https://pastebin.com/9kQu85WV setxkbmap -print: https://pastebin.com/t3sSd7er

  • Update: After my computer went into suspend again then I took it off the charger and when I logged back in from the lock screen Function+Right arrow worked to brighten the screen. But using Fn+Up arrow to turn up the volume triggers Opera Beta (the browser I usually use) to open a new tab. But Fn+Down arrow works to lower the volume. I'm so confused with how to fix this, I don't have a clue what to do or where to ask. Thank you. – BrittanyD Aug 13 '17 at 21:15
1

I figured out what went wrong and how to fix it.

When Opera Beta was installed from cli apt-get it screwed up my keyboard shortcut keys (which I hadn't changed at all from default) and the only hint I had was the new tab opening when I tried Fn+Up arrow. I had closed Opera Beta and tried Fn+Up and it reopened Opera Beta!

I checked the keyboard shortcut keys under Mint Menu > Preferences > Keyboard Shortcuts and found that Launch web browser was set to "XF86WWW" so I disabled that. I then looked for the monitor brightness setting and there wasn't one, so I added a new one called "Monitor Brightness Up" with the text I found online "XF86MonBrightnessUp" and saved it then tried it. That worked.

I can't explain the seemingly random complete keyboard failure but hopefully since those two are fixed it won't happen again. Time will tell on that problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.