1

I have the same problem as in this question but with Ubuntu.

Reinstall man pages & fix man

I tried everything but the problem persists. When I try and view a manpage I get an empty page. What can I do about it?

When I try to view my own manpage I get this error:

$ man -l openshell2017/opsh/man/opsh.1
man: command exited with status 3: /usr/lib/man-db/zsoelim | preconv -e UTF-8 | tbl | nroff -mandoc -Tutf8
It seems the bug also is reported at this link.

It is also a bug reported at Launchpad: https://bugs.launchpad.net/ubuntu/+source/man-db/+bug/1389682

I think what I did was remove all the manpages to save disk space and then I reinstalled them.

  • 3
    1. Try to reproduce the problem by executing this pipe command manually. 2. Exit status 3 means that the last command exited with status 3, trace it with strace. – peterh Aug 13 '17 at 18:17
  • @peterh I get a strange error message when I try to run the pipeline manually: $ /usr/lib/man-db/zsoelim | /usr/lib/man-db/manconv -f UTF-8:ISO-8859-1 -t UTF> groff: pre-grohtml: Signal 11 (core dumped) – Niklas Rosencrantz Aug 14 '17 at 11:28
  • And: $ /usr/lib/man-db/zsoelim | preconv -e UTF-8 | tbl | nroff -mandoc -Tutf8 groff: can't find DESC' file groff:fatal error: invalid device utf8' – Niklas Rosencrantz Aug 14 '17 at 11:29
2

groff: can't find DESC' file groff:fatal error: invalid device utf8

That suggests your groff setup is borked or you have more than one and man is using the wrong one.

Changing your locale to "C" (dispensing with UTF-8 for now, in that shell) might make your your manpages viewable again. You want to look at grops(1) and grotty(1), in the FILES section. That will tell you where the grops/grotty DESC file is; there should be one for UTF-8, too.

In my system, I have

$ ls /usr/share/groff/1.22.3/font/dev[aup]*/DESC
/usr/share/groff/1.22.3/font/devascii/DESC
/usr/share/groff/1.22.3/font/devpdf/DESC
/usr/share/groff/1.22.3/font/devps/DESC
/usr/share/groff/1.22.3/font/devutf8/DESC

If you don't find devutf8/DESC, your groff installation is incomplete (wrt to UTF-8). If you do find it, you'll want to make see if you have two groff installations and, if so, if man(1) is using the right one.

To verify your groff installation can render your man page without man(1), you can use groff directly,

$ nroff -t -e -mandoc openshell2017/opsh/man/opsh.1 | less 
2

I ran into this issue (which was down to disk corruption in my case) and I fixed it by reinstalling the groff-base package:

sudo apt-get install --reinstall groff-base

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.