7

I am running the i3 window manager with Debian 9 Stretch on a laptop with a trackpad.

I have run into the problem that whenever I type, the mouse is disabled. Is this normal behavior or a bug?

nonfree repos have been enabled and linux-firmware-nonfree has been installed. The bug does not show up on other distributions.

This does not happen with a USB mouse

xinput output

Virtual core pointer                        id=2    [master pointer  (3)]
Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
ETPS/2 Elantech Touchpad                    id=11   [slave  pointer  (2)]

Virtual core keyboard                       id=3    [master keyboard (2)]
Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
Video Bus                                   id=7    [slave  keyboard (3)]
Power Button                                id=8    [slave  keyboard (3)]
HP TrueVision HD                            id=9    [slave  keyboard (3)]
AT Translated Set 2 keyboard                id=10   [slave  keyboard (3)]
HP Wireless hotkeys                         id=12   [slave  keyboard (3)]
HP WMI hotkeys                              id=13   [slave  keyboard (3)]
Power Button                                id=6    [slave  keyboard (3)]

Touchpad Properties

Device 'ETPS/2 Elantech Touchpad':
    Device Enabled (142):   1
    Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Tapping Enabled (277): 0
    libinput Tapping Enabled Default (278): 0
    libinput Tapping Drag Enabled (279):    1
    libinput Tapping Drag Enabled Default (280):    1
    libinput Tapping Drag Lock Enabled (281):   0
    libinput Tapping Drag Lock Enabled Default (282):   0
    libinput Tapping Button Mapping Enabled (283):  1, 0
    libinput Tapping Button Mapping Default (284):  1, 0
    libinput Accel Speed (285): 0.000000
    libinput Accel Speed Default (286): 0.000000
    libinput Natural Scrolling Enabled (287):   0
    libinput Natural Scrolling Enabled Default (288):   0
    libinput Send Events Modes Available (262): 1, 1
    libinput Send Events Mode Enabled (263):    0, 0
    libinput Send Events Mode Enabled Default (264):    0, 0
    libinput Left Handed Enabled (289): 0
    libinput Left Handed Enabled Default (290): 0
    libinput Scroll Methods Available (291):    1, 1, 0
    libinput Scroll Method Enabled (292):   1, 0, 0
    libinput Scroll Method Enabled Default (293):   1, 0, 0
    libinput Disable While Typing Enabled (294):    1
    libinput Disable While Typing Enabled Default (295):    1
    Device Node (265):  "/dev/input/event1"
    Device Product ID (266):    2, 14
    libinput Drag Lock Buttons (296):   <no items>
    libinput Horizontal Scroll Enabled (297):   1
6
  • Some touchpads have a feature that disable touch events during typing, to avoid interpreting accidental touches. As you provide no information about your trackpad, I can't say if your trackpad has this feature. xinput can be used to list and set properties of input devices.
    – dirkt
    Commented Aug 13, 2017 at 5:26
  • I have edited my post to show the output of xinput Commented Aug 13, 2017 at 5:42
  • Now read man xinput, and list the properties of the Elantech Touchpad.
    – dirkt
    Commented Aug 13, 2017 at 5:49
  • I've listed the touchpad properties, then I tried the command xinput --set-int-prop "ETPS/T Elantech Touchpad 294 0 but I got the output "Invalid format 0" Commented Aug 13, 2017 at 6:01
  • I also tried using the actual name of the property instead of "294" Commented Aug 13, 2017 at 6:06

2 Answers 2

15

The problem I was having involved the Disable While Typing Enabled feature of my trackpad. These are the steps I used to solve it.

  1. Make sure xinput is installed.

  2. Type xinput to find the name of the trackpad device. Mine was ETPS/2 Elantech Touchpad.

  3. Run xinput --list-props "DEVICE" to list the properties of the device.

  4. Go through the list until you find something like Disable While Typing.

  5. Use

    xinput --set-prop "DEVICE" ID_OF_PROPERTY 0
    

    For me, this was

    xinput --set-prop "ETPS/2 Elantech Touchpad" 294 0
    
0

For me, with XFCE on Debian 11 only the following worked:

  1. Edit /usr/share/X11/xorg.conf.d/40-libinput.conf
  2. Comment out Option "SendEventsMode" "disabled-on-external-mouse" under inputclass with identifier libinput touchpad catchall

Mine looked like this in end:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Option "Tapping" "True"
    Option "TappingDrag" "True"
    Option "DisableWhileTyping" "True"
    Option "AccelProfile" "adaptive"
    Option "AccelSpeed" "0.4"
    #Option "SendEventsMode" "disabled-on-external-mouse"
    Driver "libinput"
EndSection

Note: I had also to restart X11 for this to take effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .