6

In Linux Mint 18.2, the default path selector looks like this:

path bar

I want it to look like this:

filename-entry

So I went opened up dconf-editor and changed org.gtk.settings.filechooser location-mode from path-bar to filename-entry. Unfortunately, this didn't have any effect, and when I opened up dconf-editor later, it had reverted back to path bar. So then I used gsettings to do it myself:

gsettings set org.gtk.Settings.FileChooser location-mode filename-entry

I tried this both with and without sudo. After running the command, gsettings get said that it did indeed take effect and was now set to filename-entry. Excited, I opened up gedit to test this, but was dismayed to find it was still the path bar and not filename-entry. Perplexingly, after closing the file-chooser in gedit, gsettings get now showed that location-mode had reverted to path-bar.

After trying this a few times, I determined that closing the file-chooser causes the setting to revert.

How can I get the file-chooser to use the path bar?

2

Having the same issue. also Linux Mint 18.2.

A workaround is to press Ctrl-L to switch to Location-entry mode.

I would also like a method to make this permanent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.