1

I have multiple regular user accounts running on Mint 17.1. root and sudoers are using the default language (in this case English), but the other accounts use different Languages. Every so often, users' locale reset to English, and will certainly happen after an apt upgrade. The way the users currently work around this is to open the terminal and run locale, log off and log back on.

Is there a permanent fix for my issue?

  • How do your users set their locale? I would recommend that they put their desired settings into their ~/.bash_profile or ~/.bash_login which shouldn't be touched on by anything that happens system-wide. – tink Aug 12 '17 at 3:02
  • @tink Will try that. Users set their own language via the GUI provided by Mint. – drum Aug 12 '17 at 3:08
  • @tink Late reply but setting LANG did nothing – drum Sep 10 '17 at 4:04
  • - how about other LC variables, e.g. LC_ALL? Btw, I find it odd that running locale should fix anything - all that does is to display values. – tink Sep 12 '17 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.