1

On Xubuntu I've used vbetool to turn off/on the display in my laptop, assigned to touchpad key because the display key didn't work. I now just installed Fedora 26 and want to use my script, but It seems that vbetool is not in the repository anymore. How can I install vbetool on Fedora 26?

I've tried to install from the source following this article How to install vbetool on CentOS 6.6? but got warnings when running make and got an error

make: *** No rule to make target '/usr/local/lib/libpci.a', needed by 'vbetool'.  Stop.
0

I've solve the problem by searching for libpci.a file on 64bit Fedora the file was located in /usr/lib64/ so runing:

sudo ln -sf /usr/lib64/libpci.a /usr/local/lib/libpci.a

and then running make again solved the issue.

So the whole solution (based on CentOS article):

sudo dnf install pciutils-devel pciutils-devel-static libx86-devel
# if you have 32bit system, just remove 64 from lib
sudo ln -sf /usr/lib64/libpci.a /usr/local/lib/libpci.a

# you can check if there are no new version 1.1 was latest when writing this
wget http://www.codon.org.uk/~mjg59/vbetool/download/vbetool-1.1.tar.gz

tar xzvf vbetool-1.1.tar.gz
cd vbetool-1.1
./configure && make && make install
0
dnf install libx86 -y 

wget http://mirror.orbit-os.com/archlinux/community/os/x86_64/vbetool-1.2.2-4-x86_64.pkg.tar.xz

xz -d vbetool-1.2.2-4-x86_64.pkg.tar.xz

tar -xvf vbetool-1.2.2-4-x86_64.pkg.tar -C /

$ vbetool 
vbetool: Usage vbetool [[vbestate save|restore]|[vbemode set|get]|
[vgamode]|[dpms on|off|standby|suspend|reduced]|[post [romfile]]|
[bootpost]|[udevpost pciid]|[vgastate on|off]|
[vbefp panelid|panelsize|getbrightness|setbrightness|invert]]

1
  • Welcome to the site and thank your for your contribution. Would you mind adding some explanation on how your approach solves the problem, i.e. what mistake the OP may have made when originally trying to install the software, which your proposed solution does correctly. – AdminBee Mar 13 '20 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.