4

I upgraded my system from fedora 25 to 26 and now mendeley desktop fails to open. I was using the version 1.16 (with latest updates). Even the latest version (1.17.10) does not work. When I run it from the terminal this is the message I'm getting:

QSslSocket: cannot resolve CRYPTO_num_locks
QSslSocket: cannot resolve CRYPTO_set_id_callback
QSslSocket: cannot resolve CRYPTO_set_locking_callback
QSslSocket: cannot resolve ERR_free_strings
QSslSocket: cannot resolve sk_new_null
QSslSocket: cannot resolve sk_push
QSslSocket: cannot resolve sk_free
QSslSocket: cannot resolve sk_num
QSslSocket: cannot resolve sk_pop_free
QSslSocket: cannot resolve sk_value
QSslSocket: cannot resolve SSL_library_init
QSslSocket: cannot resolve SSL_load_error_strings
QSslSocket: cannot resolve SSL_get_ex_new_index
QSslSocket: cannot resolve SSLv2_client_method
QSslSocket: cannot resolve SSLv23_client_method
QSslSocket: cannot resolve SSLv2_server_method
QSslSocket: cannot resolve SSLv23_server_method
QSslSocket: cannot resolve X509_STORE_CTX_get_chain
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
QSslSocket: cannot resolve SSLeay
QSslSocket: cannot resolve SSLeay_version
QSslSocket: cannot call unresolved function SSLeay
QSslSocket: cannot call unresolved function CRYPTO_num_locks
QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
QSslSocket: cannot call unresolved function SSL_library_init
QSslSocket: cannot call unresolved function SSLv23_client_method
QSslSocket: cannot call unresolved function sk_num

I have openssl, openssl-devel (version 1:1.1.0f-7), qt and qtwebkit installed. Cannot figure out the problem. I know I should ask this question in Mendeley support and I did but there is no response. As such, the support site has some problems.

2 Answers 2

6

this works for me on fedora 26:

sudo dnf install compat-openssl10-devel
2
  • This package conflicts with openssl-devel on my system. Anyway, after openssl-devel removal this answer fixes the problem. Thanks! Sep 21, 2017 at 9:52
  • I have the same problem with the 1.17.13 version in Fedora 26, but installing compat-openssl10-devel don't solve it. do you know any other reason why this problem could be triggered? Mar 21, 2018 at 21:50
2

The Fedora 26 is using OpenSSL 1.1.0 by default. Your application is probably not compatible with it yet. But you can install compat package with OpenSSL 1.0.2, which should resolve your problems:

dnf install compat-openssl10
1
  • compat-openssl10 is already installed.
    – WYSIWYG
    Aug 15, 2017 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.