2

I disabled predictable network interfaces names by changing GRUB_CMDLINE_LINUX line in /etc/default/grub from:

GRUB_CMDLINE_LINUX="pci=nomsi"

to:

GRUB_CMDLINE_LINUX="pci=nomsi net.ifnames=0"

on a fresh installation of Debian GNU/Linux testing system with installed proprietary NVIDIA drivers. I did it because my external USB Wi-Fi card didn't work with systemd interfaces names.

After disabling predictable network interfaces names I'm giving following message at boot:

A start job is running for raise network interfaces (2 minutes of 5 mins 1 sec)

and system boots long.

My /etc/network/intefaces file:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

Why am I giving this message at boot? How can I avoid long booting of my system?

6

Solved by changing file /etc/network/interfaces.d/setup from:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

to:

auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp
  • 1
    This worked for me in Debian 9.1 – Ajeeb.K.P Aug 14 '17 at 8:33
2

Disable the service that waits to start the network interfaces.

systemctl disable NetworkManager-wait-online.service

And to enable:

systemctl enable NetworkManager-wait-online.service

Alternatively you can reduce the amount of time that it waits to start the job.

vim /etc/systemd/system/network-online.target.wants/networking.service 

TimeoutStartSec=5min ##Change parameter, should be at the end of the page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.