1

I installed arch linux. As a video player i choose vlc.
i couldn't run vlc unless i installed qt4 package. Why is it needed ?
If we can't run vlc without qt4 pkg why is it not installed along with vlc.
Can anybody help me understand it ?

  • Please do let me know if i did anything wrong while installing vlc. I used 'pacman -Syu vlc' command. – krishnakant Aug 10 '17 at 15:53
4

On Arch Linux, if you execute pacman -Qi vlc, it shows you a list of Dependencies for vlc (among other information), and another list of Optional Dependencies. If you take a look at that list, there is an entry that says qt4: for the GUI.

When you install a package, pacman normally tells you what the optional dependencies are for that package. Be sure to read through these, so that you don't miss anything!

The reason that qt4 is optional (as opposed to mandatory) is that the vlc package provides you with the commands vlc and cvlc. vlc is the command for starting the graphical VLC you know already. With cvlc however, you can play a music file from your command line without opening a GUI. Because parts of the vlc package work without installing qt4, it's only listed as an optional dependency.

  • Thanks, my concerns was what is the use of vlc without gui. Didn't thought it could be used only for music. – krishnakant Aug 10 '17 at 17:20
  • still doesnt make any sense. vlc is a compiled binary, why would there ever be the need for qt libraries? this almostlooks like a dependency error – phil294 Nov 18 '18 at 19:26
  • Also, vlc can act as a streaming server or convert/rip media, none of which requires the GUI. You might be using the features on a server that doesn't even have a graphical display. – SilentVoid Mar 4 at 15:43
0

Are you certain that it requires Qt itself? When testing on my system, it does not show that dependency:

$ apt depends vlc | grep qt

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

  Depends: libqt5core5a (>= 5.5.1)
 |Depends: libqt5gui5 (>= 5.0.2)
  Depends: libqt5gui5-gles (>= 5.0.2)
  Depends: libqt5widgets5 (>= 5.2.0)
  Depends: libqt5x11extras5 (>= 5.1.0)

Requiring Qt libraries is not the same as requiring Qt itself. If this is different in Arch, you might want to contact the maintainer of the Qt package in the relevant Arch repository.

  • Thanks, Yes vlc requires qt4 for the GUI, 'pacman -Qi vlc' gives qt4[for the GUI] in optional deps. I will gather more info about qt later on. – krishnakant Aug 10 '17 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.