1

I just bought two new 4TB external USB disks for backups

http://www.bestbuy.com/site/wd-my-passport-4tb-external-usb-3-0-portable-hard-drive-black/5605533.p

that came performatted with a single large ms partition. I'm running slackware 14.2x64, and ran gdisk to d(elete) that partition and make three n(ew) 1.2TB partitions (just dividing the total sectors by three). Then I w(rote) the partition table info and gdisk exited. And then both fdisk -l and gdisk -l /dev/sdb showed everything looking exactly like I'd expected it should.

But then mkfs -t ext4 /dev/sdb1 said it saw the original ms partition, and asked whether or not to proceed. I said no, and tried gdisk several more times, d(eleting) and re-n(ewing) all three partitions. Also tried sync, and tried unplugging the drive and re-plugging it. Nothing worked. I finally tried letting mkfs start to format the ms partition it reported, and killed it after a minute. Then re-ran gdisk yet again. And now, finally, mkfs saw the new partition table. And everything proceeded smoothly.

But what was I doing wrong? That is, how do you run gdisk so that the subsequent mkfs correctly and immediately sees the partition table you just w(rote) using gdisk? I wouldn't think that what I ended up doing is the recommended procedure.

2

The kernel is still using the old partition table.

Issue partprobe for the kernel to use the new partition table or reboot.

See man partprobe for the gory details.

EDIT (thanks to comments):

gdisk prints the following Warning message informing you that the kernel is still using the old partition table, inviting you to restart.

Warning: The kernel is still using the old partition table. The new table will be used at the next reboot. The operation has completed successfully.

fdisk and parted (including gparted) do the partprobe automatically and inform you whether it succeeded or not.

  • 1
    @JohnForkosh Gdisk displays a message informing you about this when you use the w command. Fdisk does the partprobe automatically and informs you whether it succeeded or not. – Gilles Aug 10 '17 at 22:21
  • Merci, Gilles! I edited my answer. – thecarpy Aug 11 '17 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.