1

i'm trying to install phpMyAdmin and I get this error

php71w-common conflicts with php-common-5.4.45-13.el6.remi.x86_64

here goes some info

# rpm -qa php\* 
php-bcmath-5.4.45-13.el6.remi.x86_64 
php-php-gettext-1.0.12-1.el6.remi.noarch 
php-xml-5.4.45-13.el6.remi.x86_64 
php-common-5.4.45-13.el6.remi.x86_64 
php-tcpdf-6.2.13-1.el6.remi.noarch 
php-cli-5.4.45-13.el6.remi.x86_64 
php-process-5.4.45-13.el6.remi.x86_64 
php-pecl-apcu-4.0.11-2.el6.remi.5.4.x86_64 
php-gd-5.4.45-13.el6.remi.x86_64 
php-mbstring-5.4.45-13.el6.remi.x86_64 
php-tcpdf-dejavu-sans-fonts-6.2.13-1.el6.remi.noarch 
php-pdo-5.4.45-13.el6.remi.x86_64 
php-tidy-5.4.45-13.el6.remi.x86_64 
php-5.4.45-13.el6.remi.x86_64 
php-mcrypt-5.4.45-13.el6.remi.x86_64 
php-fedora-autoloader-1.0.0-1.el6.remi.noarch

and php version

# php -v
PHP 5.4.45 (cli) (built: Feb 18 2017 15:55:26) 
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies

Thanks for the help


EDIT

Tried to update to PHP 5.6 # yum install php55w-pdo-5.5.38-1.w6.x86_64 and get lot of error, so tried to remove PHP with yum remove php

Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Remove Process
No Match for argument: php
Loading mirror speeds from cached hostfile
 * base: centos.xfree.com.ar
 * epel: mirror.uta.edu.ec
 * extras: centos.xfree.com.ar
 * remi: remi.xpg.com.br
 * remi-safe: remi.xpg.com.br
 * updates: centos.xfree.com.ar
 * webtatic: us-east.repo.webtatic.com
Package(s) php available, but not installed.
No Packages marked for removal

here it said not installed but it's installed

# php -v
PHP 5.5.38 (cli) (built: Feb 18 2017 08:33:29) 
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
0

You're trying to install a package for PHP 7, whilst having PHP 5 installed. Either install the relevant PHP 5 package, or upgrade your PHP installation to PHP 7 to resolve the conflict.

  • I don't want php7, so how can I make to install phpMyAdmin for php5? – Braian Mellor Aug 8 '17 at 22:38
  • Ensure that phpMyAdmin is still compatible with PHP5, and if so, follow the installation instructions for installing on that version of PHP. – DopeGhoti Aug 8 '17 at 22:56
  • thanks for your answer. Can you specify the steps? – Braian Mellor Aug 8 '17 at 22:57
  • updated with new steps – Braian Mellor Aug 8 '17 at 23:17
  • Could be a conflict or issue with packages from the remi and remi-safe repositories. I have a CentOS 6.9 Vbox image with MySQL, PostgreSQL, PHP5, and both phpMyAdmin and phpPgAdmin. All packages came from either base, epel, or extras repositories. – Deathgrip Aug 9 '17 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.