7

How can I get the KDE (Plasma 5.8.6 on Debian Stretch) System Settings for keyboard repeat & delay to actually do something?

These settings:

KDE Keyboard settings screenshot

Whenever I change and apply the settings I don't see any effect on the X11 repeat/delay state (as seen via xset q | grep "auto repeat delay").

1

1 Answer 1

8

In the Startup and Shutdown → Background Services configuration applet, make sure the Keyboard Daemon service ("Enables switching keyboard layout through shortcuts or system tray") is checked and in the "Running" state:

Keyboard Daemon service screenshot

If this does not seem to have an effect, log out and back in. The settings should be applied afterwards.

For whatever reason this service is also responsible for propagating rate/delay changes to X11, which you can see live via:

watch -n1 'xset q | grep "auto repeat delay"'

Source: bcooksley's post at KDE Community Forums.

5
  • +1 but for me this service was stopped, and the keyboard repeat still worked. However, the repeat stopped randomly at one point. It was enough for me to toggle this service to get it working again.
    – Sparhawk
    Aug 13, 2019 at 5:58
  • 3
    It is running for me. But even restarting it had no effect. Restarting the computer applied the settings, though.
    – Albert
    May 2, 2020 at 11:06
  • It was on for me, but disabling it, re-enabling it, then logging out/in finally applied my settings. Kind of annoying because I cannot test the settings without having to restart. Guess I'll file a bug report with KDE.
    – DaVince
    Aug 21, 2020 at 10:29
  • 2
    same thing as @Albert. It's running, but no effect. Can wait until restart or set this settings manually. From xset help: r rate [delay [rate]] xset r rate 150 25
    – Lordn__n
    Oct 28, 2020 at 16:10
  • This may be a bug with Wayland. The xset r rate 250 25 workaround worked without needing logging out/in. Feb 13, 2021 at 5:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .