1

I've been at this for hours going through every guide I've found and I'm still stuck.

I've installed Debian 9 from a bootable usb flash drive. I only copied the 1 DVD onto it since that's all Debian's site said I needed. I installed Debian on a whole partition (I didn't break it down into /home or anything). I installed the GNOME desktop. I DID NOT use the network install because my connection is terrible (I had to go to school to download the .iso in the first place).

My first attempt I added the chrome to /etc/apt/sources.list deb http://dl.google.com/linux/chrome/deb/ stable main

I then ran get https://dl-ssl.google.com/linux/linux_signing_key.pub

sudo apt-key add linux_signing_key.pub

sudo apt-get update

sudo apt-get install google-chrome-stable

This is what comes out:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 google-chrome-stable : Depends: gconf-service but it is not installable
                    Depends: libgconf-2-4 (>= 3.2.5) but it is not             installable
                    Depends: libappindicator1 but it is not installable
E: Unable to correct problems, you have held broken packages.

So then I tried downloading an unpacking the installer from Google itself. First I ran apt-get clean && apt-get update apt-get upgrade apt --fix-broken install Then I ran dpkg -i google-chrome-stable_current_amd64.deb from my downloads directory. That spat out

Selecting previously unselected package google-chrome-stable.
(Reading database ... 125174 files and directories currently installed.)
Preparing to unpack google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable (60.0.3112.90-1) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on gconf-service; however:
Package gconf-service is not installed.
google-chrome-stable depends on libgconf-2-4 (>= 3.2.5); however:
Package libgconf-2-4 is not installed.
google-chrome-stable depends on libappindicator1; however:
Package libappindicator1 is not installed.

dpkg: error processing package google-chrome-stable (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
 google-chrome-stable

What am I doing wrong here? I need dependencies that were not installed with the USB bootable disk but I cannot get these dependencies. I tried searching for those dependencies in the synaptic package installer but it can't find them.

  • 1
    why not just use chromium? it's chrome, spyware-lite edition, maintained by debian devs. – cas Aug 7 '17 at 2:55
  • 1
    @cas The only reason I use Google Chrome is to watch netflix. Doesn't work with Chromium sadly. – maulinglawns Aug 7 '17 at 14:54
  • Side note: dpkg doesn't automatically resolve dependencies since that process is delegated to apt. – dsstorefile1 Feb 27 '18 at 10:14
  • I overcome this error by installing the package libcurl3 after that try to install google-chrome-stable_current_i386.deb – msp9011 Jun 7 '18 at 12:00
  • I installed Chrome successfully in my Debian 9 system by following the instructions at: idroot.net/linux/install-google-chrome-debian-9 – Antony Jun 27 '18 at 9:20
2

I don't know what guide you are following, but all you have to do is go here:
https://www.google.com/chrome/index.html

Click "Download now" to download the package google-chrome-stable_current_amd64.deb.

Then install the package from wherever you downloaded it to locally.

The installer sets up sources for you in /etc/apt/sources.list.d/google-chrome.list:

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
  • This answer does not apply. The google chrome repo does not include any version of libgconf, or any other package than google-chrome* ! Therefore the failure to install libconf is not specific to google-chrome. Instead, it is a hole in how the base Debian system has been configured. Hence my answer. No offense to you, I'm just fed up with all the other voters. – sourcejedi Mar 15 at 21:17
  • Hi @sourcejedi! No offense taken. I posted what I have done to get chrome working, and it works for me on Debian 9. Best regards. – maulinglawns Mar 16 at 11:31
1

It looks like you need to download extra Debian packages, but your sources.list file does not include the full online Debian package repository.

Several people have had this problem.[1] One reason it can happen is because the Debian installer did not see an internet connection. Or you might have removed the repository at some point :-).

Make sure your /etc/apt/sources.list file contains the following lines:

# Debian release 9.x
deb http://deb.debian.org/debian stretch main
deb-src http://deb.debian.org/debian stretch main

# Security updates
deb http://deb.debian.org/debian-security/ stretch/updates main
deb-src http://deb.debian.org/debian-security/ stretch/updates main

Then run apt update. Then try the install again, with the command apt install google-chrome-stable

(apt is now the recommended command for interactive use. apt-get is less friendly, and in particular apt-get upgrade does not install some very important security updates.)

I do not know exactly what will happen after you have added the online Debian repo. I.e. whether you would have to go back and remove the online repo, if you want to install some packages from your USB (Debian DVD #1).


[1] See the comment at this link: How to install debian without games, office etc...?

0

I had the same issue and it get fixed by running the following command:

sudo apt --fix-broken install

regards.

  • I do not think you have the same issue. The question mentions that they did run "apt --fix-broken install". But even after that, "I tried searching for those dependencies [gconf-service etc.] in the synaptic package installer but it can't find them." – sourcejedi Apr 17 at 14:43
  • If you are able to reproduce your problem, or if you have saved what the errors looked like, you could write your own question. You are allowed and encouraged to post answers that you have found for your own questions. – sourcejedi Apr 17 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.