Today I was using virtual console 1 (Ctrl+Alt+F1) to chroot to another filesystem.

When I came back to the X desktop, everything worked fine, but when I tried to go back to virtual console 1 it just freezes until I hit Alt+F7 and I can move the mouse again.

Now this happens always; I cannot switch to a virtual terminal anymore, not even after a reboot.

I am using Debian testing kernel 4.11.0-1 .

I don't even know if it is a package so I can try to reinstall it.  How can I fix this?

System details: Lenovo Thinkpad t430 CPU: Intel® Core™ i5-3210M GPU: Intel HD Graphics 4000 lspci | grep -i vga: Intel Corporation 3rd Gen Core processor Graphics Controller Memory: 8Gb

  • 1
    do you get a login prompt on VC1? what do you mean by "freezes"? just that VC (or the program you're running in it)? or the entire system? – cas Aug 6 '17 at 4:41
  • No, not Even a login prompt on any vc. When i try to switch from the x server to a vc it only freezes the image, but nothing change. – whitesound Aug 6 '17 at 4:47
  • ok, probably needs some system details - cpu, ram, kernel version, gpu brand/model, and gpu driver used at least. – cas Aug 6 '17 at 6:36
  • I added more details of my system – whitesound Aug 6 '17 at 13:29

I think that answer will help you to know more about TTYs activated in your System, you have to do this command :

 systemctl list-units | grep getty

the result will give you active TTYsin your system, after this do Alt+Ctrl+F2 folowed by Alt+Ctrl+F7 or Alt+F7, and retype the commande systemctl list-units | grep getty you should see the TTY2 activated like whith an output like this :

getty@tty1.service     loaded active running   Getty on tty1
getty@tty2.service     loaded active running   Getty on tty2

if you dont have something like this that affirms that your getty.service is not activated and you should load it and enabl it.

  • yes, i can see tty2 nunning after pressing alt + f2 in systemctl, but still nothing happens. – whitesound Aug 6 '17 at 13:13
  • so TTYs are here but the is a problem in switching. – Hamza Jabbour Aug 6 '17 at 14:25
  • what are printed in /var/log/messages and in /var/log/Xorg.0.log you shoud have something like this : [ 65780.326] (II) AIGLX: Suspending AIGLX clients for VT switch [ 65856.654] (II) AIGLX: Resuming AIGLX clients after VT switch – Hamza Jabbour Aug 6 '17 at 14:34

I got it to work with this command:

systemctl restart getty-static.service

And a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.