2

I've recently installed antergos, Arch Linux distro. I have 6 GB of RAM and only 2 GB is being detected. I installed the 64-bit version. On the BIOS, there is 6 GB of memory. I have also used Ubuntu and it detects 2 GB as well. Other Linux distros do the same. I also reseated my RAM slots with no luck.

I've tried the following:

$ free -m

              total        used        free      shared  buff/cache   available
Mem:           1964        1411          80          37         472         596
Swap:          3814           0        3814

lshw -c memory

  *-cache:0
       description: L1 cache
       physical id: 5
       slot: L1-Cache
       size: 384KiB
       capacity: 384KiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=1
  *-cache:1
       description: L2 cache
       physical id: 6
       slot: L2-Cache
       size: 8MiB
       capacity: 8MiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=2
  *-cache:2
       description: L3 cache
       physical id: 7
       slot: L3-Cache
       size: 8MiB
       capacity: 8MiB
       clock: 1GHz (1.0ns)
       capabilities: pipeline-burst internal write-back unified
       configuration: level=3
  *-memory
       description: System Memory
       physical id: 2c
       slot: System board or motherboard
       size: 6GiB
     *-bank:0
          description: DIMM Synchronous [empty]
          product: Dimm0_PartNum
          vendor: Dimm0_Manufacturer
          physical id: 0
          serial: Dimm0_SerNum
          slot: Node0_Dimm0
     *-bank:1
          description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 667 MHz (1.5 ns)
          product: 1333EL Series
          vendor: Undefined
          physical id: 1
          serial: 00000000
          slot: Node0_Dimm1
          size: 2GiB
          width: 64 bits
          clock: 667MHz (1.5ns)
     *-bank:2
          description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 667 MHz (1.5 ns)
          product: CMZ8GX3M2A160
          vendor: Corsair
          physical id: 2
          serial: 00000000
          slot: Node0_Dimm2
          size: 4GiB
          width: 64 bits
          clock: 667MHz (1.5ns)
     *-bank:3
          description: DIMM Synchronous [empty]
          product: Dimm3_PartNum
          vendor: Dimm3_Manufacturer
          physical id: 3
          serial: Dimm3_SerNum
          slot: Node0_Dimm3

# lshw -short | grep 'System Memory'

/0/2c                         memory      6GiB System Memory

$ uname -a

Linux <hostname> 4.12.4-1-ARCH #1 SMP PREEMPT Fri Jul 28 18:54:18 UTC 2017 x86_64 GNU/Linux

dmesg

[    0.000000] Linux version 4.12.4-1-ARCH (builduser@nspawn-9860) (gcc version 7.1.1 20170630 (GCC) ) #1 SMP PREEMPT Fri Jul 28 18:54:18 UTC 2017
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d597d2b0-dbcd-4e9b-8326-df9ce1547828 rw quiet resume=UUID=30a347fd-841f-4417-9dfe-c5b5ac793d4c
[    0.000000] x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x000000000009ffff] usable
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x000000007d478fff] usable
[    0.000000] BIOS-e820: [mem 0x000000007d479000-0x000000007da36fff] reserved
[    0.000000] BIOS-e820: [mem 0x000000007da37000-0x000000007de34fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000007de35000-0x000000007e101fff] reserved
[    0.000000] BIOS-e820: [mem 0x000000007e102000-0x000000007e154fff] type 20
[    0.000000] BIOS-e820: [mem 0x000000007e155000-0x000000007e155fff] usable
[    0.000000] BIOS-e820: [mem 0x000000007e156000-0x000000007e35bfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000007e35c000-0x000000007e7fffff] usable
[    0.000000] BIOS-e820: [mem 0x00000000f8000000-0x00000000fbffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec10000-0x00000000fec10fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec20000-0x00000000fec20fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed00000-0x00000000fed00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed61000-0x00000000fed70fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed80000-0x00000000fed8ffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fef00000-0x00000000ffffffff] reserved
[    0.000000] NX (Execute Disable) protection: active

closed as too broad by Rui F Ribeiro, GAD3R, cas, Stephen Rauch, Anthon Aug 6 '17 at 19:57

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    The map covers only 32 bit address space. What is the output of uname -a? – Hauke Laging Aug 6 '17 at 3:23
  • uname -a Linux cesard11 4.12.4-1-ARCH #1 SMP PREEMPT Fri Jul 28 18:54:18 UTC 2017 x86_64 GNU/Linux – Cesar D Aug 6 '17 at 3:54
  • 3
    This is not a linux problem. Often there are hw limitations where the memories have to match. For maximum chances of success, 2 DIMs of 4 GB. Beware of the limitations of the motherboard/device too. – Rui F Ribeiro Aug 6 '17 at 10:16
  • @RuiFRibeiro If that was the problem, then the BIOS should report 2GB. Cesar, what do you see in the BIOS exactly? Does it say that 6GB of memory is available, or are you adding up a report that lists the connected DIMMs? What motherboard model is it? – Gilles Aug 6 '17 at 23:36
  • Do try to put the modules in slots 0 and 1 rather than 1 and 2. – Gilles Aug 6 '17 at 23:38