0

I cant repair my audio, since I installed debian on my hp probook 650 G1. I dont even know what to search for or try to do. I got stuck at this log from pulseaudio.

(   0.102|   0.000) I: [pulseaudio] (alsa-lib)utils.c: could not open configuration file /usr/share/alsa/ucm/HDA Intel HDMI/HDA Intel HDMI.conf
(   0.102|   0.000) I: [pulseaudio] (alsa-lib)parser.c: error: could not parse configuration for card HDA Intel HDMI
(   0.102|   0.000) I: [pulseaudio] (alsa-lib)main.c: error: failed to import HDA Intel HDMI use case configuration -2
(   0.102|   0.000) I: [pulseaudio] alsa-ucm.c: UCM not available for card HDA Intel HDMI
(   0.102|   0.000) D: [pulseaudio] conf-parser.c: Parsing configuration file '/usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf'
(   0.103|   0.000) D: [pulseaudio] alsa-mixer.c: Looking at profile input:analog-mono
(   0.103|   0.000) D: [pulseaudio] alsa-mixer.c: Checking for recording on Analog Mono (analog-mono)
(   0.103|   0.000) D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
(   0.103|   0.000) I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
(   0.103|   0.000) I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No such file or directory
(   0.103|   0.000) D: [pulseaudio] alsa-mixer.c: Caching failure to open input:analog-mono
(   0.103|   0.000) D: [pulseaudio] alsa-mixer.c: Looking at profile input:analog-stereo
(   0.103|   0.000) D: [pulseaudio] alsa-mixer.c: Checking for recording on Analog Stereo (analog-stereo)
(   0.103|   0.000) D: [pulseaudio] alsa-util.c: Trying front:0 with SND_PCM_NO_AUTO_FORMAT ...
(   0.104|   0.001) I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
(   0.104|   0.000) I: [pulseaudio] alsa-util.c: Error opening PCM device front:0: No such file or directory
(   0.104|   0.000) D: [pulseaudio] alsa-util.c: Trying hw:0 with SND_PCM_NO_AUTO_FORMAT ...
(   0.104|   0.000) I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D0c' failed (-2)
(   0.104|   0.000) I: [pulseaudio] alsa-util.c: Error opening PCM device hw:0: No such file or directory
(   0.104|   0.000) D: [pulseaudio] alsa-mixer.c: Caching failure to open input:analog-stereo
(   0.104|   0.000) D: [pulseaudio] alsa-mixer.c: Looking at profile input:iec958-stereo
(   0.104|   0.000) D: [pulseaudio] alsa-mixer.c: Checking for recording on Digital Stereo (IEC958) (iec958-stereo)
(   0.104|   0.000) D: [pulseaudio] alsa-util.c: Trying iec958:0 with SND_PCM_NO_AUTO_FORMAT ...
(   0.104|   0.000) I: [pulseaudio] (alsa-lib)pcm_hw.c: open '/dev/snd/pcmC0D1c' failed (-2)
(   0.104|   0.000) I: [pulseaudio] alsa-util.c: Error opening PCM device iec958:0: No such file or directory
(   0.104|   0.000) D: [pulseaudio] alsa-mixer.c: Caching failure to open input:iec958-stereo
(   0.104|   0.000) D: [pulseaudio] alsa-mixer.c: Looking at profile output:analog-mono

Some info :

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI_1 [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI_1 [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI_1 [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci -vvv
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: snd_hda_int04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
    Subsystem: Hewlett-Packard Company RTS5227 PCI Express Card Reader
    Physical Slot: 7
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 29
    Region 0: Memory at d0400000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: rtsx_pci
    Kernel modules: rtsx_pci
el
        Kernel modules: snd_hda_intel
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
    Subsystem: Hewlett-Packard Company Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
    Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 36
    Region 0: Memory at d0830000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

More information:

Output of cat /proc/asound/cards:

0 [HDMI_1 ]: HDA-Intel - HDA Intel HDMI HDA Intel HDMI at 0xd0830000 irq 36
1 [HDMI   ]: HDA-Intel - HDA ATI HDMI HDA ATI HDMI at 0xd0740000 irq 33

aplay /usr/share/sounds/alsa/Front_Center.wav

Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

And the last one

pacmd list-sinks | grep -e 'name:' -e 'index'

* index: 0 name: <alsa_output.pci-0000_00_03.0.hdmi-stereo BTW 
  • cat /proc/asound/cards also as root or with sudo aplay /usr/share/sounds/alsa/Front_Center.wav´ and pacmd list-sinks | grep -e 'name:' -e 'index' ` – user192526 Aug 5 '17 at 15:14
  • There it is cat /proc/asound/cards 0 [HDMI_1 ]: HDA-Intel - HDA Intel HDMI HDA Intel HDMI at 0xd0830000 irq 36 1 [HDMI ]: HDA-Intel - HDA ATI HDMI HDA ATI HDMI at 0xd0740000 irq 33 An other aplay /usr/share/sounds/alsa/Front_Center.wav Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono And the last one pacmd list-sinks | grep -e 'name:' -e 'index' * index: 0 name: <alsa_output.pci-0000_00_03.0.hdmi-stereo BTW : I have no idea how to comment with syntax – Radek Pulkrabek Aug 5 '17 at 16:29
  • You don't comment with syntax, you edit the question with additional information. – dirkt Aug 8 '17 at 5:18
  • Do the /dev/snd/pcm* files actually exist? If no, have a closer look at udev (though that should work). If yes, can you stop Pulseaudio completely (verify with ps) and use the devices under ALSA (aplay -D hw:0 etc.)? – dirkt Aug 8 '17 at 5:20
2

The good one, alsa recognizes your cards, and the handover to Soundsystem is working.

Control in alsamixer if something is muted. With F6 you can choose your card For alsamixer you need apt-utils on your system. No luck?

sudo apt install pavucontrol  

Start it with pavucontrol

Tab output devices you will see 2 possibilities. For internal card choose port speakers. Tab configuration, there you can choose a profile for your card. I use at the moment my internal card with profile analog stereo duplex. With aplay /usr/share/sounds/alsa/Front_Center.wav you can control if the profile works.

  • Nothing muted. When I look into alsamixer and choose default sound card, there is bar with levels of sound as you would expect, but when i choose 0 HDA intel HDMI then there are 3 colums with no bars. When I went to try these sound profiles, there is several of them, but all have "(HDMI)" in the name. Isnt that wierd ? Anyway I tried all of them with no luck. – Radek Pulkrabek Aug 5 '17 at 17:53
  • Also, speakers are working at logind screen when I press backspace in the username bar. – Radek Pulkrabek Aug 5 '17 at 20:04
  • Then is something wrong in your $HOME or with the start of your desktop-session. I hope someone can migrate this to chat. – user192526 Aug 6 '17 at 7:17
  • Where should I look in mye $HOME for mistakes ? – Radek Pulkrabek Aug 6 '17 at 8:33
  • No I created new profile and tried audio, still not working. – Radek Pulkrabek Aug 6 '17 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.