0

My desktop with i686 CPU is currently running macOS Mavericks and I'm trying to install Fedora 26 i386 via DVD. Unfortunately, when it boots the DVD and I select "Start Fedora-Workstation-Live 26" it returns me this error a couple of seconds later:

dracut-pre-udev[358]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
dracut-pre-udev[358]: rpc.idmapd: conf_reinit: open ("(null)", 0_RDONLY) failed
dracut-pre-udev[358]: rpc.idmapd: conf_reinit: open ("(null)", 0_RDONLY) failed

Then it starts returning line after line of blk_update_request and Buffer I/O error on dev sr8.

After a few minutes, it does actually produce an error report: /run/initramfs/rdsosreport.txt but I haven't succeeded in moving the file to a USB drive. When I run $ ls dev, here's what I get:

Subdirectories of /dev/

When I plug my USB drive in, the shell returns:

sd 11:0:0:0: [sdg] No Caching mode page found
sd 11:0:0:0: [sdg] Assuming drive cache: write through

I thought this meant my USB drive was at /dev/sdg/, but after entering $ cd /dev/sdg/ it returned that it didn't exist.

I can't use the USB drive to install Fedora since computer can't boot from it. It detects the USB drive at the boot screen but it completely ignores it after that. In fact, when booting from the HDD, it treats it as a standard removable drive with nothing to boot from.

Most peculiarly, I have an old CD with Ubuntu 12.04 i686 and I booted from that, it worked perfectly fine!

Edit: I'm installing Fedora with Fedora-Workstation-Live-i386-26-1.5.iso from a DVD-RW.

Edit #2: I previously thought that there was an issue with the optical drive in my laptop, where I was burning the ISO images to the DVD. So I used ImgBurn to find the error, and sure enough there was a power calibration area error but after a few re-tries, it successfully verified the DVD. When I booted the desktop with the DVD again, the error stil occured. I tried using a different distribution: Arch Linux, using arch-anywhere-2.2.8-i686.iso and the shell returned similar results (blk_update_request and Buffer I/O error) but without the aforementioned error.

Edit #3: So far I've had three attempts of installing Fedora via Netinstall;

  1. I burned the ISO onto a DVD-RW and the system wasn't able to boot from it, it couldn't detect a bootable device.
  2. I used a brand new DVD-RW using a different optical drive. The system returned the same rpcbind.lock error like before, however it eventually got itself to the installation setup. There was an issue with the disk partitioning: the HDD has a size of around 450 GiB which already has Arch Linux installed as /, alongside /boot, swap, and the BIOS boot. The setup could only use the 1 GiB available space using the automatic installation, it wasn't able to delete any partition. Custom installation didn't really work either, swap had a bug where it was confined to a maximum of 1024 MiB where the setup rejected that parameter and required that it should be around 5 GiB. It crashed at the Advanced Custom installation, completely shutting down the installation setup.
  3. At my third attempt, using the same DVD, the shell returned that X2-compressed data was corrupt. A few seconds later, kernel panic:

    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
    

Edit #4: Now I can't login through GDM, the screen at the default GDM background. I've made a separate question on this.

  • Are you running the live media from the USB drive/CD or a full version. You will need be be running the live version. – Raman Sailopal Aug 4 '17 at 13:11
  • I'm running Fedora-Workstation-Live-i386-26-1.5.iso from a DVD-RW. I'll edit the question to mention that. – Pradana Aumars Aug 4 '17 at 13:13
  • How old is this computer? How much memory does it have? What if you use the netinstall image instead of the live image? What if you use the netinstall and boot it in text mode? – mattdm Aug 4 '17 at 16:09
  • It has a Intel Core 2 (released in 2010), that makes it around 5 years old more or less. 3363 MB of RAM. I'll try netinstall soon. I'll keep it posted. – Pradana Aumars Aug 4 '17 at 16:14
  • Netinstall has worked, however, at my first attempt, it didn't boot from the DVD (it couldn't detect it), on my second attempt (I burned a brand new DVD-RW), it worked! It's capable of reaching the installation process! However, I still receive the same rpcbind.lock error as before. What does this refer to actually? – Pradana Aumars Aug 4 '17 at 21:44
1

I have not yet reached a direct answer to this issue, but I believe it's due to the fact the system is using a non-EFI motherboard.

I was eventually able to install Fedora using a Netinstall version, however I had several attempts where the system either did not boot from disc or the disc was corrupt. However, during installation, the boot was not able to fully install, I did my research and found that I had to reinstall GRUB2. The problem was that the motherboard (an ASUS P5QL PRO) did not support UEFI and therefore did not have a boot mode. Unless there is a way to install Fedora without UEFI but that's something else entirely.

Here's a quick summary:

  • I was able to boot from most of the discs I used burned incorrectly. There was no error when burning, however my optical drive wasn't in the best condition and using a different drive solved half of the problem.
  • The motherboard did not support UEFI and therefore could not install bootloader properly. I tried to reinstall GRUB2, but that ultimately failed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.