I'm using "pure" Debian 9 alongside with DWM (no desktop-environment) on my laptop. After the installation, I had to install pulseaudio package in order to make the sound work. It worked well but suddenly the sound doesn't play anymore. I'm not sure what action caused this (whether it was upgrading some package or something else).

I don't see any errors anywhere; it just doesn't play. I've checked on Windows that the speakers work, so it's not a hardware problem.

When I issue pulseaudio --start --log-target=syslog and look to the syslog, there are no errors there.

Can anyone help me how to solve this problem? Write in the comments what logs or configs should I paste there.


With help of my friend I installed the pavucontrol package and found out that the sound has been muted. I don't know how it got itself to this state, but simple clicking the button solved my problem.

| improve this answer | |
  • Another way is to open a terminal and run alsamixer. – Mike Waters Aug 4 '17 at 18:27
  • I'd tried that, but it didn't work. Or maybe I just didn't find the controll which is responsible for muting. – Martin Heralecký Aug 4 '17 at 18:28
  • 1
    @MartinHeralecký you press m key when the given volume control is active to mute/unmute that device I believe. – spinkus Sep 1 '17 at 0:41
pulseaudio --kill

pulseaudio --start
| improve this answer | |

somehow across reboots pavucontrol seemed to have muted the sound. No idea why, nothing in logs. But adjusting in that application fixed it.

| improve this answer | |

this button in pavocontrol needs to be released

enter image description here

| improve this answer | |

It could be related to some problems with upgraded packages on Debian. I run into similar problem last month and I also use Debian Stretch.

After several hours of investigation I ran across this Debian bugreport which says that timidity daemon may cause the problem because it blocks the sound card:


You may try to kill the timidity as root. On my computer it immediately solves the problem:

sudo killall timidity
| improve this answer | |

If you have problems with the sound of the HDMI, install this

$ sudo apt-get install firmware-linux-nonfree \
    libgl1-mesa-dri xserver-xorg-video-ati

And restart your system and you should have working audio with your hdmi output.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.