2

I'm tryng to update my mysql (currently at version 5.6) to 5.7 on my Debian 8, however I get this error when I'm reaching the last step.

cat /etc/apt/sources.list

gives the following:

deb http://ftp.debian.org/debian/ jessie main
deb http://security.debian.org/ jessie/updates main

Here is what I did so far:

wget http://dev.mysql.com/get/mysql-apt-config_0.7.3-1_all.deb
sudo dpkg -i mysql-apt-config_0.7.3-1_all.deb 
(I then selected Mysql-server 5.7 during the configuration)
sudo apt-get update
sudo apt-get install mysql-community-sever

The output is the following:

The following packages have unmet dependencies:
 mysql-community-server : Depends: mysql-client (= 5.7.19-1debian8)
E: Unable to correct problems, you have held broken packages.

I did try to do the following:

sudo apt-get clean && apt-get update

but it did absolutely nothing.

What else can i do to fix this?

EDIT

I dug a bit this "packages are hold" problem, and the command apt-mark showhold gives nothing.

However, if I run

apt-cache policy -o =hold

I get a (long) list of packages that looks like this:

500 http://repo.mysql.com/apt/debian/ jessie/mysql-utilities-1.5 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=mysql-utilities-1.5 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/router-2.0 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=router-2.0 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/connector-python-2.1 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=connector-python-2.1 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/connector-python-2.0 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=connector-python-2.0 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/mysql-cluster-7.6 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=mysql-cluster-7.6 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/mysql-cluster-7.5 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=mysql-cluster-7.5 origin repo.mysql.com 500 http://repo.mysql.com/apt/debian/ jessie/mysql-5.7 amd64 Packages release o=MySQL,n=jessie,l=MySQL,c=mysql-5.7

But if I do

apt-mark yarn unhold

Debian tells me that yarn (for example) was already mark as unhold.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.