1

Well, I noticed a pattern but it tells me nothing. First started happening while I was on Linux Mint 18.2 After a while, I installed Antergos where it continued. It happens mostly immediately after grub loads. To remedy the situation I have to reboot multiple times until the boot goes through. Seldom the screen goes off after booting fully. Rarely while I am watching a video or playing OA. In the system log I consistently find this report:

[drm:atom_op_jump [radeon]] *ERROR* atombios stuck in loop for more than 5secs aborting

I tried searching this error on the web, most of the things I found was pretty old solved ubuntu bugs to do with intel graphics working at the same time as the amd, which is also what i have, amd being:

[raa@raa ~]$ lspci | grep -i VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Redwood XT [Radeon HD 5670/5690/5730]

The thing is my intel is disabled.

[raa@raa ~]$ lspci -vnnn | perl -lne 'print if /^\d+\:.+(\[\S+\:\S+\])/' | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood XT [Radeon HD 5670/5690/5730] [1002:68d8] (prog-if 00 [VGA controller])

Please help me solve(or at least determine) this annoying issue?

0

So the problem was that Linux has a hard time with some of the AMD graphics cards. For Mint/Debian systems, add 'nomodeset' to grub (kernel boot parameters). This works for many users with AMD/ATI-vga. Since I had made the edit from a bootup system, I changed the /etc/default/grub through the terminal where you just change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet spalsh" through nano editor. The difference between arch and debian is that where updating debian grub you use the command sudo update-grub on arch you have to sudo grub-mkconfig -o /boot/grub/grub.cfg and that's it. For more information visit https://wiki.archlinux.org/index.php/kernel_mode_setting

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.