-2

I'm running Linux Mint 18.1 on my main machine. All of my software is up to date. I have internet access through this and all other machines on my intranet, however my main machine is nowhere to be seen in my network through samba.

I have a laptop running Linux Mint 18.2 (xfce), and when I single-click the Browse Network shortcut in the default file manager then double-click Windows Network in the file manager get the error message "Failed to retrieve share list from server: No such file or directory."

sudo systemctl restart smb returns Failed to restart smb.service: Unit smb.service not found.

sudo systemctl restart smbd returns silently with no errors, as far as I know.

sudo /etc/init.d/smbd status declares the service is active and running.

I added the line item server services = s3fs under the [global] section as suggested by @Thomas, then hit sudo /etc/init.d/smbd force-reload, which returned [ ok ] Reloading smbd configuration (via systemctl): smbd.service.

...and I still receive the same error when trying to browse to my main machine using my laptop. Two different Samba browsers on my smartphone declare there is no server at the IP address where my router and my main machine say it should be.

Running smbclient -d2 -L ###.###.###.### -U ###### on my main machine returns thusly (all #######s are stand-ins for strings I don't want to post here):

rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "syslog" option is deprecated
added interface enp2s0 ip=###.###.###.### bcast=###.###.###.### netmask=###.###.###.###
Enter ######'s password: 
session setup failed: NT_STATUS_NO_LOGON_SERVERS

Here is the (updated) breakdown of my smb.conf as seen through testparm:

# Global parameters
[global]
    workgroup = #######
    server string = #######
    server role = standalone server
    security = DOMAIN
    map to guest = Bad User
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    unix password sync = Yes
    syslog = 0
    log file = /var/log/samba/log.%m
    max log size = 1000
    dns proxy = No
    panic action = /usr/share/samba/panic-action %d
    server services = s3f
    idmap config * : backend = tdb


[printers]
    comment = All Printers
    path = /var/spool/samba
    create mask = 0700
    printable = Yes
    browseable = No


[print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers
    valid users = #######
    read only = No
    browseable = No


[data]
    path = /mnt/data
    valid users = #######
    read only = No
    browseable = No

Any insights or suggestions are appreciated. Banging my head against the wall here.

  • Just a guess, but you might have to add server services = s3fs in the global section. – Thomas Aug 1 '17 at 18:39
  • @Thomas: added server services = s3fs. no dice. – Richard LeClair Aug 1 '17 at 19:15
  • changed security = USER to security = DOMAIN then restarted all machines. Now, laptop shows an icon for the appropriate smb workgroup in the file manager, but when double-clicked it says Failed to retrieve share list from server: Connection timed out. – Richard LeClair Aug 1 '17 at 20:39
  • @Hunter I've made many edits does this give you anything to work with? – Richard LeClair Aug 1 '17 at 22:25
1

I had to set browseable = Yes under my [data] section. I would have been able to browse my data share from all my devices just fine, if this were done. However, I was glazing over the fact that I had set browseable = No, because I knew that the thing I had changed to break my Samba was not that setting.

However, since I was relying on the browsability of my main machine through my laptop in order to determine the operability of Samba, I was only frustrating myself.

After changing security = USER to security = DOMAIN, and then running sudo /etc/init.d/smbd force-reload, I discovered I was able to sync my phone just as before. I wondered how this was possible, and realized that when I set up my phone so long ago, I provided it with absolute paths to all the necessary sync folders. DUH.

So I typed the absolute path for my data share into my laptop (smb://###.###.###.###/data), and I found that everything works just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.