0

I have downloaded the latest elasticsearch version 5.5.1 on my Centos 7 server from https://www.elastic.co/downloads/elasticsearch. I have unzipped the file and store it in elasticsearch directory.

I have tried to start the elasticsearch using the below commands (Reference: https://www.elastic.co/guide/en/elasticsearch/reference/current/zip-targz.html):

1)./bin/elasticsearch

Error: Permission denied

2) sudo ./bin/elasticsearch

Error: sudo: ./bin/elasticsearch: command not found Although there is no administrator user on my server.

3)cd bin
./elasticsearch

Error Permission denied

4) cd bin
sudo ./elasticsearch

Error: sudo: ./elasticsearch: command not found

5) cd bin
./elasticsearch.in.sh

This command doesn't give me output

When I do wget http://localhost:9200, I get:

--2017-08-01 14:01:25--  http://localhost:9200/
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:9200... failed: Connection refused.
Connecting to localhost (localhost)|127.0.0.1|:9200... failed: Connection refused.

May I know is this the right way to start the elasticsearch on a centos server. Do I have to change any setting in the configuration file before starting it.

  • please run ls -al elasticsearch.in.sh in the directory where it is and let me see the output – George Udosen Aug 1 '17 at 19:01
  • 1
    Is Error: Permission denied the full error message? If not, please include the full error output. Elastic also provides RPMs that might be a bit easier to get started with elastic.co/guide/en/elasticsearch/reference/current/rpm.html – Steven D Aug 1 '17 at 19:02
  • @george The output is: -rw-rw-r--. 1 centos centos 8075 Jul 18 23:42 elasticsearch – Rose Aug 1 '17 at 19:02
  • @steeve Yes. It;s the only error. I can try to install using rpms – Rose Aug 1 '17 at 19:03
1

Ok please make it executable with:

sudo chmod +x elasticsearch.in.sh

Then run it sudo ./elasticsearch.in.sh

And we have the option to use an rpm package from here, Download the file elasticsearch-5.5.1.rpm and install with:

sudo rpm -ivh elasticsearch-5.5.1.rpm
  • Thanks. I made elasticsearch executed and ran ./elasticsearch from the bin folder. It worked – Rose Aug 1 '17 at 20:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.