1

I am trying to install Debian 9, to one of my laptops, that I have never got to boot into 64 bit.

However I did switch the kernel to 64bit. I then used multi-arch to install 64bit virtual-box (this has to match the kernel), and some other 64 bit packages.

I suspect it is 32bit grub, and 64bit kernel.

Unfortunately this has left user land as, mostly, 32bit. I want it all 64bit, but to be able to boot, and install. It seems that I could replace all apps with 64bit, and then remove all 32bit.

I would like to install 64bit directly, without having to do it twice, install 32bit, then replace with 64bit.

Could anyone tell me what installation media to use, and any special procedure.


Seems related 32bit EFI with 64 bit linux OS. Can it be done?

Laptop is Acer Aspire 5338

  • If it won't boot from amd64 install media, will it boot a amd64 system that was somehow installed? Use a different computer, install to a USB flash drive, write boot loader to the flash drive (not a partition on the drive) and see if the laptop will boot from the USB drive. If it will, then you can simply install via debootstrap – ivanivan Jul 30 '17 at 14:50
  • It did not boot hybrid cd/usb on usb when I tried it last time. I am currently torenting a multi-arch (x86 + amd64) image of debian 9. I will try that. All I know at present is that I original install 32bit x86 on it. I then changed the kernel to 32bit+PAE, and then latter to AMD64. Then to get virtual box working with the 64bit kernel I installed multi-arch, and virtual-box 64bit. – ctrl-alt-delor Jul 30 '17 at 14:58
  • brand/model of laptop would be useful info for anyone trying to answer this. have you tried googling for linux + your laptop's brand/model? or debian + brand/model? – cas Jul 30 '17 at 15:00
  • Since you can start a 64-bit kernel with your current bootloader setup, the method outlined in unix.stackexchange.com/a/222387/119808 should work. – Ferenc Wágner Jul 31 '17 at 20:17
  • I have just install. I will check that it is 64bit tomorrow. If so I will write an answer. – ctrl-alt-delor Jul 31 '17 at 21:42
0

I have just installed debian-9.1.0-amd64-i386-netinst without trouble. I chose options: amd64, and custom install, however I did not do anything clever with custom install (just manual partition set up, to use existing partitions, and only install base+kde+sshd).

On the grub set up I chose fall back to install to removable media path (may have not quoted that 100% correct). It has something to do with fixing a bug in some EFI boot-loader firmware. (It may not have been needed, but the internet says it is safe if you don't have another OS installed). [If booting does not work for you, then you can reinstall Grub from rescue-mode. And experiment]

I did no experimenting, it just worked first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.