0

I am trying to install some software called CRISPResso on my mac using sudo pip install. When I type the command CRISPResso --help I get the following message.

You need to install and have the command #####needle##### in your PATH variable to use CRISPResso!

I next installed EMBOSS-6.6.0 which contains needle, after doing ./configure followed by make I get the following error

Making install in plplot
Making install in lib
make[3]: Nothing to be done for `install-exec-am'.
 ../.././install-sh -c -d '/usr/local/share/EMBOSS'
 /usr/bin/install -c -m 644 plstnd5.fnt plxtnd5.fnt '/usr/local/share/EMBOSS'
/bin/sh ../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../ajax/core  -I../ajax/core -I/usr/X11/include -I./ -I/usr/include/gd -DPREFIX=\"/usr/local\" -DBUILD_DIR=\".\" -DDRV_DIR=\".\" -DEMBOSS_TOP=\"/Users/hc/Downloads/EMBOSS-6.6.0\" -DAJ_MACOSXLF  -O2  -I/usr/X11/include -MT gd.lo -MD -MP -MF .deps/gd.Tpo -c -o gd.lo gd.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../ajax/core -I../ajax/core -I/usr/X11/include -I./ -I/usr/include/gd -DPREFIX=\"/usr/local\" -DBUILD_DIR=\".\" -DDRV_DIR=\".\" -DEMBOSS_TOP=\"/Users/hc/Downloads/EMBOSS-6.6.0\" -DAJ_MACOSXLF -O2 -I/usr/X11/include -MT gd.lo -MD -MP -MF .deps/gd.Tpo -c gd.c  -fno-common -DPIC -o .libs/gd.o
gd.c:127:16: fatal error: gd.h: No such file or directory
compilation terminated.
make[2]: *** [gd.lo] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1

I have also tried sudo make install and I get the same error.

Any suggestions on what is going wrong here?

Many thanks!

2

You probably need to install the GD library (http://www.libgd.org/).

2

The following bit of output:

fatal error: gd.h: No such file or directory compilation terminated.

Is telling you that you are missing a header file required by the program. In C programs, header files typically contain function declarations and other bits of code that describe the API of a library being used by that program.

In this case gd.h belongs to libgd. How to get this depends on your operating system. You often need to install two packages, 1 for the shared library and another for the headers (libgd and libgd-devel for example).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.