I'm on the latest Linux Mint release on an Acer Aspire S3. Unfortunately I can't set the screen brightness in the Screen preferences. It doesn't matter which position the slider has, it's always the same brightness. Am I doing something wrong? Is there another way to set the brightness?

  • this still happens with Linux Mint 13 (Maya) May 23, 2012 at 21:28
  • Still happening with Mint 16. :(
    – GreenMatt
    Oct 6, 2014 at 2:00

6 Answers 6


Changing the grub command line is the right way to do it, but the problem is that acpi_backlight=vendor is wrong. The correct one is: acpi_osi=Linux

It still always worked for me on a lot of laptops.

  • 1
    This answer should get more attention. With acpi_backlight=vendor I got full brightness on my screen (so not as dark as it was without it), but no control over brightness. The acpi_osi=Linux argument did it both. Dec 25, 2014 at 15:05
  • This answer worked for me with an ASUS K501UX with same results as @ShlomiNoach.
    – markmuetz
    Oct 12, 2016 at 9:30

The solution from @RoQ is working fine. Here are the steps :

  • Edit the /etc/default/grub file with superuser privilege
  • Change GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi=Linux"
  • Update the grub with the following command : sudo update-grub and reboot your computer

That's it


I am looking at fixing this in my LMDE 13 and came across this How do I set default brightness after boot?.

It has fixed it for many, however in my case, I am not able to find a directory in /sys/class/backlight. Perhaps that means a proper driver is not loaded.

  • Thanks for your reply. That would be a workaround, but I actually also need to be able to adjust the brightness using the FN key and not just telling it how bright the screen should be. When I'm on battery I don't want it to be max brightness, on AC I do. Sep 11, 2012 at 16:19

For mint mate 17, you can set the default brightness by following steps:

  • sudo apt-get install dconf-tools
  • Applications -> System Tools -> dconf tools,
  • search for backlight, find and change following options:
    • brightness-ac: brightness when use AC powser (charged),
    • brightness-dim-battery: brightness when use battery (not charged),

For all of you running a Laptop with NVIDIA Card and who are still not able to get the f* function keys for brightness to work, just follow the steps below. It worked very well for my system (Samsung q45, Intel Dualcore T7100 @ 1,8Ghz , Nvidia Geforce 8400M G 512) running Linux Mint 17.

In command line, type in:

sudo gedit /etc/X11/xorg.conf

You will have to enter your root password.

Now, you should see:

Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection

If you see nothing, just enter all the lines above and follow up with the next step below

Under the VendorName Line, add the following:

Option "RegistryDwords" "EnableBrightnessControl=1"

Now, save and reboot. Check your brightness controls, and hopefully this fixed things.

I've tried so many solutions out of the net and nothing had helped me until I came to this solution. But be aware that these steps only working for NVIDIA Grafics and you must have chosen the NVIDIA Driver in your system in "Administration -> Driver Manager".


I added acpi_osi= to grub and this helped my Acer 5742z with intel graphics.

Not the answer you're looking for? Browse other questions tagged .