0

Plasma gives me the following error after closing Apper:

KDEInit could not launch '/usr/bin/apper'

Prior to this I had a problem of high CPU load and rebuild the kservice desktop file with kbuildsycoca5, restarted plasma and then restarted my PC. I also cleaned cache and memory with BleachBit. And I tried to uninstall OpenJDK and deleted the "suspicious" files /usr/lib/jvm/.java-1.8.0-openjdk-amd64.jinfo and /usr/lib/jvm/.java-gcj-6.jinfo. However I already tried reinstalling OpenJDK which also restored those 2 files. Note that when running sudo dpkg --verify those 2 files are now shown too. Edit: debsums|grep -v OK tells me they are missing.

Also note that otherwise apper seems to be working fine.

When running sudo apper I get this in the console:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QCommandLineParser: option not defined: "install-mime-type"
QCommandLineParser: option not defined: "install-package-name"
QCommandLineParser: option not defined: "install-provide-file"
QCommandLineParser: option not defined: "install-catalog"
QCommandLineParser: option not defined: "remove-package-by-file"
Reusing existing ksycoca
Recreating ksycoca file ("/root/.cache/ksycoca5_...", version 303)
Still in the time dict (i.e. deleted files) ("apps")
Menu "applications-kmenuedit.menu" not found.
new: "/usr/share/applications/openjdk-8-policytool.desktop"
Saving
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Invalid pixmap specified.
Invalid pixmap specified.
QObject::connect: No such slot MainUi::setCaption(QString)
QObject::connect: (sender name: 'ApperKCM')

I'm running Debian 9.1 with KDE. Still new to GNU/Linux and any help is welcome.

Edit: It works again after I reinstalled those 2 packages via apt-get install --reinstall gcj-6-jre-headles & apt-get install --reinstall openjdk-8-jre-headless:amd64. However I still frequently get this message when closing apper.

0

try in terminal: "sudo apper" that should fix that problem.

Just set to run from user account.

Right Click on Apper icon: Properties>Program>Advanced options>Run as another user: "your user name"

That works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.