0

I am trying to set up a Docker container that runs from the base amazonlinux and install the Oracle version of the jdk but it keep failing on with the error:

error: Failed dependencies:
    /usr/bin/find is needed by jdk1.8.0_144-2000:1.8.0_144-fcs.x86_64

I have tried yum installing find but no packages of that name exist. I have tried googling but using the word "find" is not returning any helpful information. not sure what I am missing

3

/usr/bin/find is a part if findutils package in RHEL and systems based on it (which amazonlinux is). So you have to install findutils to fix your dependency.

1

You can check what package provides a particular executable with

yum provides /usr/bin/find

I get (on Fedora 24):

 $ yum provides /usr/bin/find
 ...
 findutils-1:4.6.0-7.fc24.x86_64 : The GNU versions of find utilities (find and xargs)
 Repo        : @System
 ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.