0

I am setting up a ftp server on my Ubuntu 16.

After using the following command:

sudo ufw allow 21/tcp
sudo ufw status verbose

I can see the output that says:

21/tcp ALLOW IN Anywhere

But, if I type:

netstat -tnlp

It does not show the port 21 at all

Do I am doing something wrong?

3

netstat will only show the port if a service or other program is actually listening for incoming connections on that port. Is your FTP service running?

  • It seems that vsftpd is not working at all. When I run netstat -a | grep ftp ti does not show vsftpd – Carlos Jul 27 '17 at 17:14
  • Also, i tried: sudo service vsftpd start and after hitting ENTER I dont get any output that says the service is running or the PID. – Carlos Jul 27 '17 at 17:15
  • 1
    That's why netstat shows what it does, then. – Jeff Schaller Jul 27 '17 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.