1

An update for logitech unifying receiver constantly pop-ups but when I tried to update it will just fail.

I also tried this

sudo fwupdmgr refresh && fwupdmgr update

But I will just got this

Fetching metadata https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz
Downloading…           [****************************************]
Fetching signature https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz.asc
Downloading…           [****************************************]
Downloading RQR12.07_B0029 for Unifying Receiver...
Updating RQR12.07_B0029 on Unifying Receiver...
Writing…               failed to erase fw @0x00: failed to send data: Device 046d:aaaa has not been opened

Then I need to re-plugin it again for it to work.

ref: https://blogs.gnome.org/hughsie/2017/05/22/updating-logitech-hardware-on-linux/

2
  • You presumably need root for both operations, so sudo fwupdmgr update.
    – meuh
    Commented Jul 27, 2017 at 7:51
  • @meuh I tried both command on sudo but got the same error.
    – zer09
    Commented Jul 27, 2017 at 10:32

1 Answer 1

4

I also had that problem in Fedora 26. Today they released an update that should solve the issue.
Update the packages and repeat the procedure you have done before:

sudo fwupdmgr refresh 
sudo fwupdmgr update

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .