0

Question:

I would like to re-install the nvidia driver on a 32 bit ARM computer running Linux for Tegra (L4T), however I don't know what the correct version of this driver is, where to get it, or how to install it properly.

Background:

I am trying to connect to an NVidia Jetson TK1 (32 bit ARM computer) using remote desktop. When I run startx in terminal freezes at Loading extension GLX.

I ran sha1sum -c /etc/nv_tegra_release and at first libglx.so checksum FAILED (maybe apt-get upgrade broke it or something), but I replaced it with the original and now it says OK.

/usr/lib/xorg/modules/extensions/libglx.so: OK

Unfortunately, that did NOT solve the problem ....

The consensus (mainly drawn from people with the same issue but different hardware), is that next I should purge and re-install the appropriate nvidia-xyz driver matching my graphics card.

Board:

Tegra K1 SOC NVIDIA Kepler GPU with 192 CUDA Cores NVIDIA 4-Plus-1™ Quad-Core ARM® Cortex™-A15 CPU

Linux Distribution: head -n 1 /etc/nv_tegra_release

R19 (release), REVISION: 2.0, GCID: 3896695, BOARD: ardbeg, EABI: hard, DATE: Fri Apr 18 23:10:46 UTC 2014

2

Refer here: https://developer.nvidia.com/embedded/linux-tegra

And you can find whole required materials about Jetson here: https://developer.nvidia.com/embedded/downloads

http://developer.nvidia.com/embedded/dlc/l4t-Jetson-TK1-Driver-Package-R21-5

http://developer.nvidia.com/embedded/dlc/l4t-Jetson-TK1-Sample-Root-Filesystem-R21-5

Although I did not test remote desktop as you did, my Jetson-TK1 has R21 (rev 5.0).

ubuntu@tegra-ubuntu:~$ head -n 1 /etc/nv_tegra_release    
# R21 (release), REVISION: 5.0, GCID: 7273100, BOARD: ardbeg, EABI: hard, DATE: Wed Jun  8 04:19:09 UTC 2016

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.