1

I know this question has been asked before but I trully don't understand how to make it work on my computer too.

I have two video cards

lspci | grep VGA

01:00.0 VGA compatible controller: NVIDIA Corporation GF110 [GeForce GTX 570 Rev. 2] (rev a1) 02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)

I have 4 monitors plugged in the 2 video cards. I have dual boot (the windows is working with all 4 monitors and it took me like 2-3 minutes to make it working)

enter image description here

Nvidia X Server Settings detects me the four monitors but it requires me to create 2 separate X Screens (namely X Screen 1 and X Screen 2). By default, it shows me the 2 monitors from the 1st video card correctly, and I can only see a black screen with an X cursor on the 3-4 monitor from the 2nd video card. Moreover when I run the xrandr

enter image description here

xrandr has only shown me the first 2 monitors. I have never been able to make xrandr show me the 3 and 4th monitor. Never. I think there is a major bug.

This is the xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 375.26  (buildmeister@vm-ubuntu1604-x64-001)  Thu Dec  8 19:58:55 PST 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ GW2255"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"

    # HorizSync source: unknown, VertRefresh source: unknown
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "BenQG2222HDL"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 570"
    BusID          "PCI:1:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
    BusID          "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DVI-I-1: nvidia-auto-select +1920+0, HDMI-0: nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +1920+0, VGA-0: nvidia-auto-select +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "VGA-0: nvidia-auto-select +0+0, HDMI-0: nvidia-auto-select +1920+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Moreover, I have tried also a personalized xorg file that has only one screen and Base Mosaic turned on but with no luck.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "BenQ GW2255"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection


Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "BenQG2222HDL"
    HorizSync       0.0 - 0.0
    VertRefresh     0.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    BoardName      "GeForce GTX 570"
    Option         "ConnectedMonitor" "DFP-0,DFP-1"
    Option         "MetaModeOrientation" "DFP-0 LeftOf DFP-1"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option         "ConnectedMonitor" "DFP-1,CRT-1"
    Option         "MetaModeOrientation" "DFP-1 LeftOf CRT-1"
    BoardName      "GeForce 210"
    BusID          "PCI:2:0:0"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DPY-1: nvidia-auto-select @1920x1080 +1920+0
  {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DPY-2: nvidia-auto-select   @1920x1080 +0+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}  DPY-4: nvidia-auto-select @1920x1080 +0+0   {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}, DPY-6: nvidia-auto-select  @1920x1080 +1920+0 {ViewPortIn=1920x1080, ViewPortOut=1920x1080+0+0}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I tried the Base mosaic too.. Nothing it purely doesn't work! Please help me. Linux monitors settings ( xorg ) drive me nuts!!!

1

I found the solution, namely the Ubuntu default desktop environment doesn't support 4 monitors. Once, I have installed XFCE, my 4 monitors worked perfectly!!!

I have found this explanation from this guy's tutorial http://collaboradev.com/2016/09/30/arch-linux-hydra-build/

0

-For you configure this and use better the videos you need activeted the "Xinerama". Take a look it here - https://help.ubuntu.com/community/XineramaHowTo

  • hi @Paulo. I have read this unix.stackexchange.com/questions/123862/… but still with no luck. Probably I am missing something - but I don't get it. I have tried Xinerama before by clicking the Xinerama option in the NVIDIA X Servers, but because the video cards are different that uses different NVIDIA drivers I get an error messages when I reboot the system – LinuxFan22 Jul 26 '17 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.