1

I am migrating from Quagga to BIRD; however after setting things up, the other OSPF "routers" do not see me.

I think I have not setup properly the MD5 directive.

My similar setup in Quagga is:

ip ospf authentication message-digest
ip ospf message-digest-key 5 md5 SecreTPassword

In BIRD I have done:

area 0.0.0.0 {

    ...

    interface "eth0" {
        cost 1000;
        password "SecreTPassword";
        authentication cryptographic;
    };

    ...
};

What is wrong?

0

It was not working because the MD5 digest authentication key (5) was forgotten.

          area 0.0.0.0 {

            ...

            interface "eth0" {

                    cost 1000;
                    password "SecreTPassword" {
                        id 5;
                    };
                    authentication cryptographic;
            };

           ...
    };

After setting it up, and restarting BIRD, the other OSPF aware routers starting listing the BIRD router in the OSPF neighbors list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.