0

I downloaded the Fedora 26 Media Creation tool, made my USB bootable, and then installed Fedora 26 onto a partition I had made on my boot drive. I booted into Fedora, selected the free partition and downloaded Fedora.

However, I can't boot into Windows now. I googled around a bit and it looks like I may be in Legacy Boot mode? I tried changing settings in my BIOS from Legacy mode to UEFI. But when I switch the settings to UEFI I get no bootable device. I know my windows installation wasn't erased because I can still see all the files and directories on that partition.

My bios options are Storage Boot Option Control and Boot Mode Selection for differentiating between Legacy and UEFI

  • If "legacy" was used before, you shouldn't need to switch to UEFI. Did you change the boot order of your devices? Try to load the one with GRUB (by default, it's the disk where you've installed Fedora on). GRUB should give you different boot-options like: Fedora Kernel XY, Fedora Rescue Image and Windows. If not, what did you get instead? – Michael Hirschler Jul 26 '17 at 8:10
  • I have two Fedora Kernel XYs and a Fedora Rescue Image. Only the first Kernel XY actually does anything. Looks like the other options just load forever. Not sure if it matters, but I also did a nvidia driver install following this guide: if-not-true-then-false.com/2015/fedora-nvidia-guide there's a grub2-mkconfig commmand that i had to run for it. Not sure if that would effect it? – Levi Murray Jul 26 '17 at 14:00
  • Run it. It is what I wanted to suggest now: the grub2-mkconfig scans your system for all runable OS'es. If Windows wont show up while doing so, grub is not able to find it, and we need to look what happened. :-) – Michael Hirschler Jul 26 '17 at 14:23
0

I had the same problem. You have to reinstall the Master Boot Record. Here's what I did:

  1. Recreate the Fedora USB using UEFI mode. If you don't have livecd-tools installed already, run:

     su -c 'dnf install livecd-tools'
    

    Then run:

     su -c "livecd-iso-to-disk --format --reset-mbr --efi Fedora-Workstation-Live-x86_64-27-1.1.iso /dev/sdX" 
    

    Obviously make sure you have the correct iso and USB drive name. You can find the correct drive name with: sudo fdisk -l

  2. Make sure legacy mode is disabled in the BIOS.

  3. Reinstall Fedora from the recreated USB.

  4. Boot into your Windows installation USB, select "Repair your computer", then "Troubleshoot", then "Command Prompt".

  5. Run command:

    bootrec /fixmbr
    
  6. Reboot. Windows will probably still be missing from your computer's OS selection. Boot back into the Windows Install USB, choose the Repair option again and this time click "Startup Repair". It will do its thing and then reboot again.

  7. Windows should be available in the computer's OS selection screen now. If you want to get it to show in grub, you need to rebuild it:

     sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
    

There may be other - possibly more efficient - ways of fixing it, but that's how I did it.

  • Thanks. But yeah, I ended up fixing this by simply just deleting the fedora partition, and reinstalling fedora, which ended up fixing my boot record. – Levi Murray Aug 8 '17 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.