Mint 18.2 64b
Cinnamon 3.4.3

This is running in a VM on my machine so I'm not worried about login security. I've been looking around on the Mint forums and only found a lot of threads about troubleshooting problems with autologin.

The setting is not in the Login Window settings screen.

The setting is not in the Users and Groups settings screen.

Where is this setting located now?

  • 1
    cat /etc/X11/default-display-manager
    – user192526
    Jul 26, 2017 at 6:04
  • /usr/sbin/lightdm
    – jcollum
    Jul 26, 2017 at 14:21
  • 2
    Not sure if it works like in xenial. Create the file /etc/lightdm/lightdm.conf.d/lightdm.conf with following content. [Seat:*] autologin-user = your_username
    – user192526
    Jul 26, 2017 at 15:18
  • 1
    Clarification for future readers: this problem appears to be specific to Mint 18.2. In most other versions (including 18.1 and 18.3), the setting should be found in the Users tab of the Login Screen window, as described in Keith's answer below. Jan 24, 2019 at 10:43

4 Answers 4


It seems there isn't a GUI setting for auto-login, except during initial installation.

Bahamut already pointed to the right solution. When look at the file: /etc/X11/default-display-manager, it points to the lightdm.

Then for Mint 18.2 (Cinnamon), the correct config file for lightdm is: /etc/lightdm/lightdm.conf.

The contents of the file could contain multiple settings:

  • Where USERNAME is your username, that should be auto-logged-in.
  • autologin-enable=true - this line was added for Linux MATE 18.3 64bit, but not tested for 18.2 Cinnamon. Remove it if necessary...

PS: Even it's too late to help the OP, it could be of help for other people. Let me know if someone can't get it working.

  • Hey thanks for answering. Since you're the only one, you get the check.
    – jcollum
    Nov 16, 2017 at 16:27

I have been looking for the same answer for Mint 19. I found the following and hope that the answer helps others.

Menu-Preferences-System Settings-Login Window--Users Tab-Username---Enter username

Save and reboot


Linux Mint 18.3 Cinnamon:

I did not have that /etc/lightdm/lightdm.conf at all. Instead, I appended code suggested by "Minister" here:

sudoedit /etc/lightdm/lightdm.conf.d/70-linuxmint.conf

and it works.


click menu search for login window then go to users then you will see automatic login type username in all lower case login window

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.