9

I have an installation of openSUSE 11.4 which was installed in German. I started Yast2 (which displayed in German, like "Netzwerkdienste") and switched the language to English under "System" -> "Sprache".

Yast2 downloaded some files, installed something and remained German ("Netzwerkdienste" can still be seen instead of, presumably, "Network Services").

I rebooted the machine, same result.

I un-installed the German Yast language pack. Yast2 persists in displaying in German.

I don't know how many of Yast2's screens are supposed to be translated, but I think it might only be the main screen that is in German. However, it is annoying. How can I change it?

Update:

I checked environment variables (for the root user). There are several variables that refer to language settings and all remain set to German.

declare -x LANG="de_DE.utf8"
declare -x LANGUAGE="de_DE.utf8"
declare -x LC_ALL="de_DE.utf8"

Shouldn't Yast2 have modified them?

Update:

I just started vi and it's also in German... does the language setting in Yast2 do anything at all?

0

Try to change settings in /etc/sysconfig/language file for system-wide, or ~/.i18n/language for individual user.

  • for english - update all entries in file from de_DE to en_US f.e. – user1024 Dec 4 '16 at 9:38
  • You can edit posts. – phk Dec 18 '16 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.