1

I installed kubuntu 16.04 (amd64) on my laptop.

I want access by ssh to my laptop. What's I do?

sudo apt-get update
sudo apt-get install openssh-server
sudo ufw allow 22

Now I can connect from my another PC to my laptop by ssh. OK. But I still have 2 issues:

1) just power on my laptop. I see logging screen. But I can not connect by ssh now, because my laptop do not connected to network at this moment. If I logging, then I see notification about connection to wifi. And now I can connect by ssh. Can I config, that my laptop will be connected to network before any user logged in?

2) I logged to my laptop. I can connect by ssh too. Then I logout. Now I can not connect by ssh, but I can ping my laptop success. Is available solution for this case?

0

When you configured your WiFi access you probably did not check something like "Allow to use this connection for all users", which means that until you are locally logged-in the WiFi is not turned on, which explains why you can not access your laptop remotely.

If you log in, and then go into the System Preferences related to Network/WiFi you should be able to change your connection to make sure it is available for all users and hence should be set up automatically at boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.