All video file in my pc can be played by ffplay,it is strangle video files can't be played by vlc .
Here are some my vlc configure.

enter image description here enter image description here enter image description here

The vlc in my pc will auto exit when to open video file,what is the matter? Are there some package lost?
How to check it?

dpkg -l | grep vlc
ii  browser-plugin-vlc                    2.0.6-4                              amd64        multimedia plugin for web browsers based on VLC
ii  libvlc-dev                            2.2.6-1~deb8u1                       amd64        development files for libvlc
ii  libvlc5                               2.2.6-1~deb8u1                       amd64        multimedia player and streamer library
ii  libvlccore-dev                        2.2.6-1~deb8u1                       amd64        development files for libvlccore
ii  libvlccore8                           2.2.6-1~deb8u1                       amd64        base library for VLC and its modules
ii  vlc                                   2.2.6-1~deb8u1                       amd64        multimedia player and streamer
ii  vlc-data                              2.2.6-1~deb8u1                       all          Common data for VLC
ii  vlc-nox                               2.2.6-1~deb8u1                       amd64        multimedia player and streamer (without X support)
ii  vlc-plugin-notify                     2.2.6-1~deb8u1                       amd64        LibNotify plugin for VLC
ii  vlc-plugin-pulse                      2.2.6-1~deb8u1                       all          transitional dummy package for vlc
ii  vlc-plugin-samba                      2.2.6-1~deb8u1                       amd64        Samba plugin for VLC

enter image description here enter image description here enter image description here enter image description here

cvlc test.mp4
VLC media player 2.2.6 Umbrella (revision 2.2.6-0-g1aae78981c)
[00000000025bbb08] dummy interface: using the dummy interface module...
Segmentation fault
uname -a
Linux MiWiFi 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64 GNU/Linux

It is no use to do the following three commands in my pc.

sudo /usr/lib/vlc/vlc-cache-gen -f usr/lib/vlc/plugins
sudo apt-get update
sudo apt-get install --reinstall vlc

Smplayer was installed too,both of all can't play video ,when to play video,the error output in smplayer is as below.

MPlayer2 2.0-728-g2c378c7-4+b1 (C) 2000-2012 MPlayer Team Terminal type `unknown' is not defined.

Playing /home/debian8/test.mp4.
Cache size set to 2048 KiB

Cache fill:  0.00% (0 bytes)   
Detected file format: QuickTime / MOV (libavformat)

MPlayer interrupted by signal 11 in module: demux_open
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.
  • There isn't enough information here to help you. Try running VLC from the command line with debug enabled, like this: VLC_VERBOSE=3 vlc <file> and post the output. – Guss Jul 25 '17 at 8:10
  • 4
  • Guss ask me to paste all the output by command VLC_VERBOSE=3 vlc <file>,the content is so long that stackvoerflow warn me not to post it.I had to post in the form of image. – it_is_a_literature Jul 27 '17 at 22:28
  • No waring again ,done. – it_is_a_literature Jul 27 '17 at 22:28
  • This is a segmentation fault, thus a bug in VLC, not a decoding problem (VLC has probably the right codec to display the video). – xhienne Jul 27 '17 at 22:51

This question reminds me of some problems that may cause this:

1) is video enabled in vlc at all?

  • Tools -> Preferences -> Video tab
  • See if Enable video box is checked,if not enable it .
  • See if Window decorations is checked, if not check it.
  • Set the Output drop-down menu to X11 video output (XCB).

2)In case of downloading video files from torrent, at some points they may show false 100% download, and the file is corrupted and can't be played.

3)If mplayer also can't play the video, check it with other video files.

4)reinstalling vlc sometimes mess things up, I suggest to do :

sudo apt-get update
sudo apt-get remove --purge vlc
sudo apt-get install vlc

5) Tool -> preferences -> Input / Codecs under Codecs, if "Hardware-accelerated decoding" is "disabled" edit it to "Automatic."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.