So I'm trying to install Debian 9.0 to my laptop (UEFI) via DVD and everything worked fine except that the mousepad doesn't work (yet?) and that I'm getting this error:

Debootstrap error
Failed to determine the codename for the release.

at the step "install the base system" after the partitioning.

Any suggestions for what I should try to get it working?
This thread somewhat suggests that some change to my partitioning could solve this issue.
I selected "Guided - Use entire disk and set up encrypted LVM". Changing the 2 ext4 partitions to ext3 didn't help.
Any help is welcome!

Edit: I skipped to step "Check integrity of the CD" and it says The CD of yours is not a valid Debian-CD-ROM. Please change the CD. Note that during installation I connected to the Internet and that I used the same CD for the installation on another PC. Please help.

Edit: Related question of mine. I rebooted and did the integrity-check offline where it says: "Integrity test failed The ./pool/main/k/kde-l10n-de_16.04.3-1_all.deb file failed the MD5 checksum verification. Your CR-ROM or this file may have been corrupted."

  • No, You should download a new image , you cannot install the OS with a corrupted iso.
    – GAD3R
    Jul 24, 2017 at 18:34
  • @GAD3R Well I did. From what I know I used that labelled CD for the installation of Debian on my PC. Of course I won't used that CD again but it seems to have worked.
    – mYnDstrEAm
    Jul 24, 2017 at 23:46
  • I had a similar issue after a lot of fiddling around to no result, I redid the partition step. After that it worked. This is probably not a general solution, but it worths a try. Aug 9, 2018 at 8:57

4 Answers 4


This question is old but I just came across a working fix for this.

As it turns out, the issue was caused due to the USB drive being unmounted during the LVM setup process. It might've been a bad USB connector or USB drive.

There is a very easy fix for which you don't even have to reboot or re-do any of the setup again.

  1. Press esc to enter the menu of the installer.
  2. Select Enter a shell (or command prompt)
  3. Run fdisk -l to find out the name and partition of your USB install drive
  4. Run mount /dev/sdc1 /cdrom (replace sdc1 with your USB drive)
  5. Run exit, then go back to Install the base system from the menu

It will continue to install as normal. All credits and thanks go to this guy

On Debian 10 busybox there is no fdisk command, so you can list disk and their partitions using ls /dev/sd*. Once you find your USB partition go to step 4.

  • it says "/bin/sh: fdisk: not found". What to do? I am trying to install Debian 10?
    – Pranav
    Sep 6, 2019 at 2:52
  • 1
    Curiously, in my case mount showed that the USB drive /dev/sdd1 was mounted at /cdrom, but ls /cdrom yielded empty. The device had somehow moved to /dev/sde during the partition setup, apparently. Mounting it again fixed the problem.
    – alvherre
    Jun 12, 2020 at 16:29
  • 1
    for fdisk: not found running blkid command worked for me.
    – Don Grem
    Dec 30, 2020 at 16:37
  • This happened when I was trying to use a specific Debian 10 Live ISO image for standard (no X11), non-free firmware. Apr 25, 2021 at 0:57
  • I had the same problem with Devuan Chimera, and this solution (module it being /dev/sr1) solved it. Thanks.
    – CarlF
    Mar 6, 2023 at 1:35

I just had the exact same problem when trying to install with an encrypted LVM. I saw the "Failed to determine the codename for the release" error, and when I checked the validity of the image I also got that same error.

I found that by rebooting and restarting the installation but cancelling when it got into the lengthy process of overwriting the whole hard drive with random data, the error didn't reoccur.

I'm guessing that something happened to the USB mount during the multi-hour disk wiping process, and rebooting fixed it.

It's kind of weird that checking the integrity of the image is one of the last things on the list. Why not check it before using it to install everything?


I received this error when I used the nonfree version of the debian distribution. Free version worked just fine and without issue. I believe the issue is because the install guide fails to load part of the codebase, and therefore cannot perform the partition functions because of missing code. For example, looking at the busybox commands, there is no mount or ls commands.


Recent Stretch 9.8.0 Gnome DVD, via Transmission (torrent) for my GF's old ASUS laptop: I noted that my Verbatim DVD disks are intended for data/media, not booting. (These disks have a movie film reel illustration on the front of the DVDs.)

Previously, I had noted your problem with the USB flashdrive too--in tandem with another such Verbatim DVD. Actually, that image on my Verbatim DVD then was supposed to be limited to net install (netinst) for a CD. (I was in a hurry and couldn't locate my CDs.) I got a message that the "CD" was invalid. Anyway, the disk wouldn't boot.

I then tried a Philips DVD-R (burned with same Gnome image as this latter Verbatim, burned just a few minutes before), and was then able to install that. Thus, I was able to format the / partition correctly as bootable beforehand in installation, too. The filesize of the iso and number of files on both disks were identical.

Moral: I made the mistake of using a DVD instead of a CD, for a CD image--and also using unsuitable media--which seems intended basically for data and entertainment content, not booting isos. It seems to me here that the media used does matter: Beware! (I need to learn to use thumbdrives correctly for this install function, also.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .