1

I've been trying to install a few windows games with wine on Linux Mint 10 (based on ubuntu 10.10), but I am finding that my cd-rom mount points aren't standard.

ie: rather than /media/cdrom I get /media/disc_name [ a la /media/Warcraft\ III]

This seems to cause problems during the installation of multi-disc games, and games which require the disc to be in the drive after installation. In both cases the target disc cannot be found, even when the mount point is verified to match the original installation source, or updated in the installer to match the location of the second disc due to autonaming.

Any ideas what I could do here? Near all cases result in a file not found error.

1

If you don't mind mounting the disks manually, add the following line to /etc/fstab:

/dev/cdrom  /media/cdrom  auto  noauto,user,exec

Then you can use mount /media/cdrom when you insert a disk, and umount /media/cdrom before ejecting it.

You'll need to either figure out how to disable any automatic mounting, or undo that automatic mounting (with umount). You can also move a mount point with mount --move ' /media/Warcraft III' /media/cdrom (this needs to be run as root).

  • I'll test these out tonight and see what I find. For now I'm accepting your answer, combined with the comment :) – Gopherkhan Nov 8 '10 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.