2

When I open nautilus and right-click in a folder, there is an option "Open Terminal Here". Before updating to Debian 9, I had a Keyboard Shortcut set in the file ~/.config/nautilus/accels, where I uncommented the line

(gtk_accel_path "<Actions>/ExtensionsMenuGroup/TerminalNautilus:OpenFolderLocal" "F12")

After updating, it doesn't work. The menu item is still there on right-click in nautilus but the accel doesn't work anymore. Does anyone have a solution to this?

2

I'm an Ubuntu 18.04 user (with GNOME 3.28.3) and this have worked wonderfully for me. Hope it does for you too :)

Since version 3.15.4 Nautilus doesn't load the accel file anymore (Source).

Fortunatelly there's a better aproach in order to get what you want. Long explanation/useful resources can be found here and also here. In short:

  1. Create a script called Terminal (yes, without a extension) inside the folder ~/.local/share/nautilus/scripts with the following content:

    # !/bin/sh
    gnome-terminal
    
  2. Make it executable, then close any Nautilus instance:

    chmod +x Terminal
    nautilus -q
    
  3. Create (or edit) the ~/.config/nautilus/scripts-accels file adding these lines:

    F4 Terminal
    ; Commented lines must have a space after the semicolon
    ; Examples of other key combinations:
    ; <Control>F12 Terminal
    ; <Alt>F12 Terminal
    ; <Shift>F12 Terminal
    
  4. Test it! Open Nautilus, right click, and choose Scripts > Terminal. Or, use the keyboard shortcut that you've just configured :)

  • 1
    +1:Thank you, works for Ubuntu 18.10 GNOME Shell 3.30.1 too. – wasmup Mar 3 '19 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.