2

I've been configured a keyboard shortcuts and it is working with others. it doesn't work only with gksudo's window and special system menus. (my laptop is running with Linux Mint 18.2)

below command is just example for watching gksudo's window.

$ gksudo "gnome-terminal -e 'dmesg -w'"

how can I fix this problems?

1

Run gksu-properties and set "Grab mode" on disable, now your shortcut should work.


Alternatively:

Add some delay to your key bindings and press it before running gksudo, for example using scrot you can run something like:

scrot -d 5 FILE_NAME
  • -d 5 5 second dealay
  • wow, nice! it works on my laptop. – jay k Jul 23 '17 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.