I'm using Linux Mint 12 and I have an Asus PCE-N15 wireless card, which is running the Windows driver. Anyway, periodically I completely lose my connection, though Network Manager and iwconfig still claim that it's fine. If I ping my wireless router continually, I get something like the following:

64 bytes from icmp_req=2368 ttl=64 time=132 ms
64 bytes from icmp_req=2369 ttl=64 time=1239 ms
64 bytes from icmp_req=2370 ttl=64 time=1098 ms
64 bytes from icmp_req=2371 ttl=64 time=848 ms
From icmp_seq=2408 Destination Host Unreachable
From icmp_seq=2409 Destination Host Unreachable
From icmp_seq=2412 Destination Host Unreachable
From icmp_seq=2415 Destination Host Unreachable

The connection strength should not be an issue, nor do I believe that the router itself is the problem, as I do not have similar symptoms on any other computers.

Interestingly, the problem seems to be correlated with my usage of the computer. When I'm not making any TCP requests, the continuous ping hums along fine, with an average latency of less than 10 ms. But when I start making requests, the average latency jumps way up and I start getting "Destination Host Unreachable".

For reference here are the outputs of route, ifconfig, and iwconfig. None of these seems to be any different when I'm unable to ping the router.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 wlan0
link-local      *          U     1000   0        0 wlan0     *        U     2      0        0 wlan0

wlan0     Link encap:Ethernet  HWaddr 14:da:e9:f2:4b:b4  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::16da:e9ff:fef2:4bb4/64 Scope:Link
          RX packets:610537 errors:0 dropped:0 overruns:0 frame:0
          TX packets:594181 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:511435072 (511.4 MB)  TX bytes:81176260 (81.1 MB)

wlan0     IEEE 802.11bgn  ESSID:"Network"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: C0:C1:C0:53:A9:DA   
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=51/70  Signal level=-59 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:14   Missed beacon:0
  • 1
    All signs point to an issue with your router. What is the router model? How did you configure it? Are you the only one using it? Commented May 8, 2012 at 0:22
  • It's a linksys E2000. The majority of the settings are the "out-of-the-box" settings. I have a few other computers that have not been having trouble with it. Is there any sort of test I could run to isolate the source of the error?
    – Ben
    Commented May 8, 2012 at 3:07
  • You have not provided any information about your environment. Are there other wi-fi access points? Are there any possible sources of interference such as a microwave oven or a non-DECT 6.0 cordless phone? (If I want to blow my wi-fi connection away all I usually need to do is pop something into the microwave.) Commented May 15, 2012 at 12:52
  • 1
    I tried lots of different things, (channel, antenna, etc.), but eventually it turned out to be a combination of two factors: (1) room geometry, the type of the antenna, its position in the room and relative to me can make a big difference, and (2) the network manager; it seems that the reported strength is not always accurate, and varies with different software; switching to wicd seemed to make a huge difference, though I'm not entirely sure why that's the case. At any rate, my connection is now stable enough to use.
    – Ben
    Commented Jan 3, 2013 at 20:57

1 Answer 1


I get the same thing, from time to time. It's annoying, and might be caused by interference from other nearby wifi networks.

I fix it by going into the router settings (easier said than done, when it's not working well) and change the wifi channel. There are a number of channels to choose from, numbered from 1 to 11 or 14, or whatever your router happens to support (and local regulation allow) and you can pick whichever you wish. Unfortunately I can't tell you how to find that option on your model, but I'd be surprised if it didn't have one.

If you happen to have an Android phone, you might like to check out the free "Wifi Analyzer" app: it can tell you what channels are least crowded.


Possibility number two is that your machine has a less-well supported wireless chipset/card. I had this too: it seemed to work fine in my old house, but when I moved I had all sorts of trouble, but only with that one machine - the others seemed fine. (It also seemed to run fine when I booted into Windows, but I didn't do that often, so I could be mistaken.) Presumably the difference was that I had changed to a new 802.11n router when I moved (and got a new ISP), whereas the old one had been an ancient 802.11b model; it could also be just simply the construction of the house, or something, causing unfortunate reflections.

I eventually solved the problem by buying an external USB wifi dongle. This also had the advantage of upgrading my laptop from 802.11g to 802.11n to match the router, which was a bonus. You need to make sure it's supported by Linux though, because the drivers that come with it will do you no good; google is your friend.

BTW, my wireless chipset was a broadcom 4312, if I remember correctly.

  • Well, I tried changing the router's channel to one that was not in use, but that didn't seem to fix the problem.
    – Ben
    Commented May 8, 2012 at 22:03
  • I've edited my answer to include another experience I had with wireless.
    – ams
    Commented May 9, 2012 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .