4

enter image description here

This is how my grub looks like when I start the system up now

I added this line to my /etc/default/grub

GRUB_BACKGROUND=''

to unset the default background, but I want to set this blue color to black. How do I do it?

I do not want to set a black background image in order to make it appear black. I want to set the background color to solid black.

uname -a gives me the following output

Linux earth 4.9.0-kali4-amd64 #1 SMP Debian 4.9.30-2kali1 (2017-06-22) x86_64 GNU/Linux
1

The Debian wiki states that the grub menu colors can be changed by creating a file /boot/grub/custom.cfg with for example the following content

set color_normal=light-gray/black

This worked for me on Debian Stretch and may work on other Debian based distributions.

0

As you know, /etc/default/grub is the place to configure this. Now that GRUB_BACKGROUND is unset, you are most of the way. There are two other options that should be of interest to you.

  • GRUB_COLOR_NORMAL="foreground/background": sets the colours of a line that is not currently selected
  • GRUB_COLOR_HIGHLIGHT="foreground/background": sets the colours of the currently selected line

If you ensure that background is set to black in both of these options ypou should have the effect that you are after. This works on a system with grub 2.02 If this doesn't work, try setting GRUB_TERMINAL_OUTPUT=console.

  • Just tried, it did not work. :( I tried GRUB_COLOR_NORMAL="foreground/background" and GRUB_COLOR_NORMAL="foreground" and GRUB_COLOR_NORMAL="background" and GRUB_COLOR_NORMAL="BLACK" and GRUB_COLOR_NORMAL="" and same options with GRUB_COLOR_HIGHLIGHT` and also I mentioned GRUB_TERMINAL_OUTPUT=console but the color did not change from blue to black – GypsyCosmonaut Aug 1 '17 at 21:30
  • The foreground and background in the answer are just placeholder values. try GRUB_COLOR_HIGHLIGHT="light-blue/black" and GRUB_COLOR_NORMAL="light-cyan/black". – rlf Aug 2 '17 at 9:26
  • Tried and saw no change again, it's still the same. Also it's worth mentioning that after changing /etc/default/grub, I'm doing update-grub and then init 6 – GypsyCosmonaut Aug 2 '17 at 9:44
  • I think that there is something specific to your distribution that is overwriting your changes. Based on the fact that you're using the update-grub wrapper script rather than grub-mkconfig directly, I'm guessing you're using something Debian based. Check in /etc/grub.d/05_debian_theme, seems like you're falling back to the "traditional Debian blue theme". – rlf Aug 2 '17 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.