0

I've tried to include min protocol = SMB2 to improve the security of my local Linux machines. But when I do this, I get time out from within KDE and Operation Not Supported from CLI.

Removing the min protocol stipulation resolves this issue. Any idea why?

testparm:

Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[msc_media_public]"
Processing section "[msc_media_personal]"
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
WARNING: You have some share names that are longer than 12 characters.
These may not be accessible to some older clients.
(Eg. Windows9x, WindowsMe, and smbclient prior to Samba 3.0.)
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

definitions:

[global]
        workgroup = SG1
        server role = standalone server
        map to guest = Bad User
        obey pam restrictions = Yes
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        server min protocol = SMB3
        dns proxy = No
        usershare allow guests = Yes
        panic action = /usr/share/samba/panic-action %d
        idmap config * : backend = tdb


[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        create mask = 0700
        directory mask = 0700
        inherit acls = Yes


[msc_media_public]
        comment = REDACTED
        path = /xx/xx/xx/xx/xx
        force group = mediagroup
        read only = No
        create mask = 0664
        directory mask = 0775


[msc_media_personal]
        comment = REDACTED
        path = /xx/xx/xx/xx/xx
        read only = No
        create mask = 0775
        directory mask = 0775
        guest ok = Yes


[printers]
        comment = All Printers
        path = /var/spool/samba
        create mask = 0600
        printable = Yes
        print ok = Yes
        browseable = No


[print$]
        comment = Printer Drivers
        path = /var/lib/samba/printers

My /etc/fstab entry for mounting this drive remotely is:

//xx.xx.xx.xx/sharename /local/name/ cifs uid=1001,gid=1002,username=user,password=pass 0 0
  • Check your smb.conf for errors with testparm command. – GAD3R Jul 23 '17 at 17:09
  • I've added the results, but no errors returned... – aSystemOverload Jul 24 '17 at 20:51
  • are you also defining the level of protocol when nounting those dirs in linux clients? – Rui F Ribeiro Jul 24 '17 at 21:43
  • Don't think so, I've added my fstab entry – aSystemOverload Jul 24 '17 at 21:55
0

To have a more stable connection that does not drop when inactive, and more performance when doing SMB transfers, you need to add the "vers" option to your fstab mount options, with at least the 2.1 version, as in "vers=2.1", and then remount your SMB mountpoints.

See CIFS randomly losing connection to Windows share for more details.

Otherwise the default is (normally) for the negotiation to try to mount them as CIFS 1.0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.