1

I have a dual boot system: Kali Linux + Windows 10, on two different partitions. There are two other partitions I use for storage. They are accessible. I can mount them, but I'm unable to write to them.

I've been trying to fix them: e2fsck -b 32768 /dev/sda3 but it says it can't work on an NTFS partition:

root@kali-rev:/home/rev# e2fsck -b 32768 /dev/sda3
e2fsck 1.43.4 (31-Jan-2017)
e2fsck: Bad magic number in super-block while trying to open /dev/sda3

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

/dev/sda3 contains a ntfs file system

That is what I get for all my NTFS partitions.

My fstab:

# /etc/fstab: static file system information.  
#  
# <file system> <mount point>   <type>  <options>       <dump>  <pass>  

#Entry for /dev/sda5 :  
UUID=92dcad4f-3256-4908-b299-90edc8bd5dbf   /   ext4    errors=remount-ro   0     
#Entry for /dev/sda3 :  
UUID=08BDB5EF06C52B43   /media/rev/08BDB5EF06C52B43 ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0  
#Entry for /dev/sda4 :  
UUID=5431214957EBF5D7   /media/rev/5431214957EBF5D7 ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0  
#Entry for /dev/sda1 :  
UUID=63CA6D5A72F6F4CF   /media/rev/63CA6D5A72F6F4CF ntfs-3g defaults,nodev,nosuid,locale=en_US.UTF-8    0   0  
#Entry for /dev/sda6 :  
UUID=e6a455d8-8459-434b-aa0c-813ce9335041   none    swap    sw  0   0  
/dev/sr0    /media/cdrom0   udf,iso9660 user,noauto 0   0  

How can I get my partitions writable again?

Vielen dank im voraus.

Kali Linux

root@kali-rev:/home/rev# cat /etc/issue
Kali GNU/Linux Rolling \n \l
  • 5
    You really aren't going to have much success using an ext3 utility on an NTFS filesystem! – Jeff Schaller Jul 22 '17 at 19:32
  • 1
    For write-access on your ntfs-partitions, deactivate in UEFI and in windows10 fastboot. So windows is really completly shutdown. – user192526 Jul 23 '17 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.