0

I'm looking into downloading python-dev (I need it to compile something else), but apparently I can't download/install it using apt-get.

$ sudo apt-get -f install python-dev

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.11.3-4+deb6u6) but 2.11.3-4+deb6u8 is to be installed
 libc6-dev : Depends: libc6 (= 2.11.3-4+deb6u8) but 2.11.3-4+deb6u6 is to be installed
 libc6-i386 : Depends: libc6 (= 2.11.3-4+deb6u8) but 2.11.3-4+deb6u6 is to be installed
 python-dev : Depends: python2.6-dev (>= 2.6.6-1~) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I've tried installing python2.6-dev, but again says that I need other dependencies (libssl-dev). Any way to work around this problem?

Would running the 'apt-get -f install' with no packages work? (I've tried that, but then it says the following):

WARNING: The following packages cannot be authenticated!
  libc6-i386 libc6-dev libc-dev-bin libc-bin libc6
Install these packages without verification [y/N]? N

Now.... if I try to update/upgrade everything using "sudo apt-get update ; sudo apt-get upgrade", I end up getting this:

#(...)
E: Some index files failed to download, they have been ignored, or old ones used instead.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Depends: libc-bin (= 2.11.3-4+deb6u6) but 2.11.3-4+deb6u8 is installed
 libc6-dev : Depends: libc6 (= 2.11.3-4+deb6u8) but 2.11.3-4+deb6u6 is installed
 libc6-i386 : Depends: libc6 (= 2.11.3-4+deb6u8) but 2.11.3-4+deb6u6 is installed
E: Unmet dependencies. Try using -f.

Any suggestions?

Looks like I'm always running back to some issue with versions/unmatched stuff that I don't know how to handle...


For info:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 6.0.10 (squeeze)
Release:    6.0.10
Codename:   squeeze

$ apt-cache policy libc6-i386 libc6-dev libc-dev-bin libc-bin libc6 python python-dev python2.6-dev 
libc6:
  Installed: 2.11.3-4+deb6u6
  Candidate: 2.11.3-4+deb6u11
  Version table:
     2.11.3-4+deb6u11 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
 *** 2.11.3-4+deb6u6 0
        100 /var/lib/dpkg/status
     2.11.3-4 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
python:
  Installed: 2.6.6-3+squeeze7
  Candidate: 2.6.6-3+squeeze7
  Version table:
 *** 2.6.6-3+squeeze7 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
        100 /var/lib/dpkg/status
libc6-dev:
  Installed: 2.11.3-4+deb6u8
  Candidate: 2.11.3-4+deb6u11
  Version table:
     2.11.3-4+deb6u11 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
 *** 2.11.3-4+deb6u8 0
        100 /var/lib/dpkg/status
     2.11.3-4 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
libc6-i386:
  Installed: 2.11.3-4+deb6u8
  Candidate: 2.11.3-4+deb6u11
  Version table:
     2.11.3-4+deb6u11 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
 *** 2.11.3-4+deb6u8 0
        100 /var/lib/dpkg/status
     2.11.3-4 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
python-dev:
  Installed: (none)
  Candidate: 2.6.6-3+squeeze7
  Version table:
     2.6.6-3+squeeze7 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
libc-bin:
  Installed: 2.11.3-4+deb6u8
  Candidate: 2.11.3-4+deb6u11
  Version table:
     2.11.3-4+deb6u11 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
 *** 2.11.3-4+deb6u8 0
        100 /var/lib/dpkg/status
     2.11.3-4 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
libc-dev-bin:
  Installed: 2.11.3-4+deb6u8
  Candidate: 2.11.3-4+deb6u11
  Version table:
     2.11.3-4+deb6u11 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
 *** 2.11.3-4+deb6u8 0
        100 /var/lib/dpkg/status
     2.11.3-4 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
python2.6-dev:
  Installed: (none)
  Candidate: 2.6.6-8+deb6u3
  Version table:
     2.6.6-8+deb6u3 0
        500 http://http.debian.net/debian/ squeeze-lts/main amd64 Packages
     2.6.6-8+b1 0
        500 http://ftp.uk.debian.org/debian/ squeeze/main amd64 Packages
  • You’ve got mismatched libc6 packages somehow. Does apt install libc6-i386 libc6-dev libc-dev-bin libc-bin libc6 work? – Stephen Kitt Jul 22 '17 at 18:47
  • @StephenKitt no, it basically says failed to fetch everything (i.e. "Failed to fetch http.debian.net/debian/pool/main/e/eglibc/… 404 Not Found [IP: 151.101.16.204 80]" ) – PGen Jul 22 '17 at 19:08
3

You’re using Squeeze, which has reached the end of its life (since the end of February 2016 in fact). The repositories have been moved to archive.debian.org, so you need to replace all occurrences of “http.debian.net” and “ftp.uk.debian.org” in /etc/apt/sources.list with “archive.debian.org”, then run

apt-get update

again. Then apt-get upgrade should find the files it needs.

I do strongly recommend that you upgrade to a supported release...

  • yes, upgrade. squeeze (debian 6) was released in 2011. followed by wheezy (debian 6) in 2013, then jessie (debian 8) in 2015. the latest debian release is version 9, called "buster". You should upgrade to at least jessie. Unfortunately, there's no easy way to upgrade direct from squeeze to jessie or buster. You'd have to upgrade to wheezy first, then jessie, then buster. It may be easier to just backup your data and config files and reinstall from scratch. – cas Jul 23 '17 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.