2

When I am in openbox and I start terminator and inside it mc, I cannot use F10 to exit from mc because it is intercepted by terminator an terminator menu opens (same as right-mouse-click).

On terminator forum they suggest to add following into gtkrc:

binding "NoKeyboardNavigation" {
    unbind "<shift>F10"
}

class "*" binding "NoKeyboardNavigation"

This solves the problem in LXDE, when I add the above lines to

/usr/share/themes/Clearlooks/gtk-2.0/gtkrc

But it does not solve the problem in openbox, even when I am using the same theme (Clearlooks).

I have also tried adding the lines to :

~/.config/gtk-2.0/gtkrc

but still no effect in openbox.

How can I fix this problem in openbox ?

0

The standard locations for gtk2 configuration files are

  • /etc/gtk-2.0/gtkrc: system wide
  • ~/.gtkrc-2.0: user specific

Thus, try to change one of those files instead of ~/.config/gtk-2.0/gtkrc.

Actually there is some inconsistency, because gtk3 is indeed using ~/.config/gtk-3.0/settings.ini, but that is another story.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.